Home / Forums / DynamiX Support / Navigation "Posts" page

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts

  • Brian Wohn
    Participant

    When I click the next page from viewing my post page, it just pulls up page 1 again – it doesn’t open up the next batch of older posts?

    https://www.hammerheadwoodworks.com/posts/?v=8f2564d40946

    Some setting I need to check? Thanks!

    Hi @bwohn234

    Can you please send over your site’s login credentials so we can personally check the settings from our end?

    Regards,


    Brian Wohn
    Participant
    This reply has been marked as private.

    The query added at the end of the URL, ?v=8f2564d40946 , is possibly breaking pagination for the site.

    The pagination works on this URL https://www.hammerheadwoodworks.com/posts/page/2/?v=8f2564d40946 but the query is being formatted this way when clicking on the pagination numbers: https://www.hammerheadwoodworks.com/posts/?v=8f2564d40946page/2 which is not the correct format.

    Have you tried to disable all your plugins to check if any of them is adding this query or did you personally configure your site to have this query?

    Regards,


    Brian Wohn
    Participant

    I didn’t add it myself (wouldn’t know how) haha But, I will try to disable the plugins and see if thats doing it.

    Thanks much!

    Hi @bwohn234

    This is possibly added by your plugins or a rewrite on your .htaccess is adding it.

    Once you find a way to remove that query, the pagination should work again.

    Thanks!


    Brian Wohn
    Participant
    This reply has been marked as private.

    Hi @bwohn234

    1) I still see ?v=8f2564d40946 on your site’s URL

    2) Try to install the SSL Insecure Content Fixer plugin as this should help force images/CSS/JS and other files on your site to load via HTTPS instead of HTTP

    3) I think the main issue with your site is the images as it comprise 1.11MB to the total 1.9MB https://tools.pingdom.com/#!/eCvNUq/https://www.hammerheadwoodworks.com/

    The best first thing you can do is add a caching plugin to your site. Removing the query ?v=8f2564d40946 on your site’s URL will also help since this query bypassed caching, causing it to hit the server directly.

    Also, it is best to coordinate with a developer to look into speeding up your site.

    Regards,


    Brian Wohn
    Participant
    This reply has been marked as private.

    Hi @bwohn234

    Since I haven’t seen a confirmation that you have disabled your plugins to eliminate the query, can I ask if you have done that? If yes, and the query still persisted, the best option is to have your hosting provider’s support team look into the issue.

    Can you please send over your site’s FTP credentials so I can do a quick check on the current .htaccess rules for the site?

    Thanks!


    Brian Wohn
    Participant
    This reply has been marked as private.

    Hi @bwohn234

    Since you have figured out that it was WooCommerce that caused it, there is no need to check on .htaccess.

    Try to reinstall the plugin and if the issue persists, it is best to coordinate with WooCommerce’s support/community for help on the issue.

    Regards,


    Brian Wohn
    Participant

    OK, thanks again for your help!

    You’re welcome, @bwohn234

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.