Home / Forums / DynamiX Support / New members error message

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts

  • Katie Keith
    Participant

    When subscribers create a new account and view the Dashboard, they are seeing the error message “Sorry, but you don’t have the correct permissions to activate the Revolution Slider plugin”. I am not using the Revolution Slider nor do I want to activate unused plugins for no reason. Is there a way to fix this bug so that messages about inactive plugins only show for administrators.

    Thanks in advance
    Barn2Media


    Tom ( Support)
    Keymaster

    Hi,

    Try installing the plugin, then de-activating it to see if that removes the message.

    Tom


    Katie Keith
    Participant

    Hi Tom, subscribers are still getting the error message about the Rev slider – screenshot here.
    Error message

    Thanks


    Tom ( Support)
    Keymaster

    Hi Katie,

    Please can you provide your login details for both the subscriber account and the admin account so we can take a further look into this for you?

    Kind regards,
    Tom


    Katie Keith
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Katie,

    Upon further inspection, we will need further access to the files in order to fully hide it. We will need FTP details to edit the files directly.

    Please set your reply to private also.

    Kind regards,
    Tom


    Katie Keith
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Katie,

    The only way to overcome this is to edit the DynamiX/lib/inc/sub-functions.php file.

    I’ve removed this line of code:

    array(
    'name' => 'Revolution Slider', // The plugin name
    'slug' => 'revslider', // The plugin slug (typically the folder name)
    'source' => get_stylesheet_directory() . '/plugins/revslider.zip', // The plugin source
    'required' => false, // If false, the plugin is only 'recommended' instead of required
    'version' => '', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented
    'force_activation' => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch
    'force_deactivation' => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins
    'external_url' => '', // If set, overrides default API URL and points to an external URL
    ),

    This will unfortunately have to be done when updating the theme in the future.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.