Home / Forums / You Theme Support / No menu on mobile – You Theme

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts

  • Tim Hensel
    Participant

    Hi Andy

    It looks like a few others might have had the same issue, but the replies are marked as private – it looks like you went into their sites and fixed it, or it was an update version issue?

    Anyway, no menu on mobile on my site http://tinyrobot.design

    Please can you have a look for me? I’m going to go in and create you a login now.

    Lovely theme by the way, otherwise 🙂

    Cheers
    Tim Hensel


    Tim Hensel
    Participant
    This reply has been marked as private.

    Hi @timhensel

    This should now be fixed. Please check your site and confirm.

    Regards,


    Tim Hensel
    Participant

    Hi Edcel

    Sorry, still not working.

    The odd thing is it’s only on the home page that it doesn’t work – the other pages are fine. I am using two different menus, one for Home and one for the other pages, but changing it doesn’t seem to make any difference.

    I’ve also tried disabling the plugins that only affect the homepage too – but still no dice.

    Any ideas?

    Hi @timhensel

    You mentioned that you have two different menus, can you please specify which menu is for the Home? Is it the ‘Tiny Robot’ menu or ‘Who Am I Nav’ menu?

    Also, please grant us permission to disable again all your plugins for further checking.

    Regards,


    Tim Hensel
    Participant

    Hi Edcel

    It’s the “Tiny Robot” menu on Home. The other one I use on the other pages is called “WVP Menu” – the “who I am one” and the others are redundant, I imported those from my other website.

    I’ve tried both though, with no change.

    Yes please feel free to do whatever you need to.


    Tim Hensel
    Participant

    OK, so I’ve simplified the menu so there’s only one throughout the site at present. Still not appearing on home page on the mobile though.

    While I’m at it, is there a way to make the sticky menu sticky on mobile too? At the moment it follows down the page on desktop, but not on mobile where arguably this feature is more important.

    Many thanks 🙂


    Tim Hensel
    Participant

    Woohoo – I’ve fixed it.

    Apparently having the dock bar turned off hides the menu on mobile. Who knew?

    I’d still like a way to make the menu sticky on mobile though, if that’s possible.

    Hi @timhensel

    Glad you’ve fixed it!

    You may use this CSS to make the mobile dock bar sticky.

    .header-float-wrap.header_float {
        position: fixed;
    }

    Paste it inside Appearance > Theme Options > Custom CSS > Mobile CSS

    Thanks!


    Tim Hensel
    Participant

    Thank you

    Is it possible to just make the menu bars sticky though, rather than the whole header? The logo obscures the content somewhat when scrolling.


    Tim Hensel
    Participant

    Or, if that’s not possible, push the logo next to the menu bars rather than below them so less is obscured?

    Putting the logo beside the mobile menu is possible, but the logo will still obscure with the site content. If you want to see how it looks, copy this CSS and paste it into Appearance > Theme Options > Custom CSS > Mobile CSS:

    .vc_custom_1479838786384 {
        padding-top: 90px !important;
    }
    
    nav.dock-panel-wrap.animate-3d.dock_layout_4.dockpanel_type_1.skinset-dockbar.acoda-skin.top_bar {
        width: 27%;
        float: right;
        margin-top: 25px;
    }
    
    #header {
        width: 70% !important;
        margin: 0;
        float: left !important;
    }
    
    .dock-panel-wrap .dock-tab-wrapper .background-wrap{
        width: 333% !important;
        left: -244%;
        position: absolute;
    }

    Thanks!


    Tim Hensel
    Participant

    Thank you for that, it’s an improvement but as you say still obscures the content.

    It’s not possible to just make the menu bars sticky then and not the whole header?

    Can you please try these combinations of CSS:

    – Update this CSS I sent before:

    .header-float-wrap.header_float {
        position: fixed;
    }

    to:

    .header-float-wrap.header_float {
        position: absolute;
    }

    Then add this CSS to Mobile CSS as well:

    #header-wrap .dock-panel-wrap {
        position: fixed;
        right: 0;
    }

    If that does not work, please give us permission to implement the CSS personally from our end.

    Thanks!


    Tim Hensel
    Participant

    Hasn’t worked I’m afraid, yes please do go in and have a look.
    Tim

Viewing 15 posts - 1 through 15 (of 22 total)

You must be logged in to reply to this topic.