Home / Forums / DynamiX Support / OnePage layout mixed menu issue

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts

  • itbroliai
    Participant

    Hi,

    Is it possible to build mixed main menu in OnePage layout with Anchors and normal page links ? For example few menu buttons has links to “#About”, “#Contacts” and one button “Blog” for blog page. I’ve added menu buttons but I cannot navigate back to About, if I get to blog page. Tried to add full url, but then got an opposite result. I’m using DynamiX 5.0.4.

    Andy
    Andy
    Keymaster

    Hi,

    If you setup two menus, one for the main site which will have links to the OnePage page and a menu for the OnePage ( #about etc ), you can apply the “OnePage” menu to just the OnePage page… I hope that makes sense?


    itbroliai
    Participant

    Yes, it makes sense. How would you suggest to achieve this ? Maybe I can hardcode if statement and determine user’s location by slug, but where navigation container is placed ?


    Enrique
    Participant

    Hello,
    Everything goes fine, but on my cell phone, the logo image goes down over the first image of the website, and I cannot see this first image of the website. How do I take the logo image out on the cell phone? or make it smaller?
    thanks

    Andy
    Andy
    Keymaster

    Hi,

    You do not need to hardcode this. Just create the menu via Appearance > Menus and then set the main menu ( non-onepage menu ) via Appearance > Menus > Manage Locations and then on the OnePage page, change the menu in the Page Config settings.

    @egalindom, please create a new thread with a link to your site that has the issue, thanks.


    itbroliai
    Participant

    Thank you that solved my problem !


    Enrique
    Participant

    If I change this:
    Floating Header
    SELECT: **Normal** Float Float + Transparent

    And select normal, is the only way to see the image.
    look http://dricloud.com/
    I can see the image, but I see a awful white line between the menu and the firs image.

    If I select Float or transparent I do not see the image

    Andy
    Andy
    Keymaster

    Hi,

    You can edit the row and add no-margin-top to the class field.


    Enrique
    Participant

    sorry, where exactly do I add this?
    thanks


    Enrique
    Participant

    ok, done !!! thanks very much


    Laurent Wiart
    Participant

    Hi,

    I do have a question related to this topic: How do I link to an anchor in a one page from another page?

    Example:
    – I have a home page with 3 slides with the following anchors: #slide1, #side2, #slide3, and a menu for this page. Clicking in the menu entries works fine. I get to the corresponding slide
    – I do have another page on which I set another menu, and I want to add menu entries to go to #slide2 and #slide3 in the home page.
    Unfortunately, if I have in this menu something like “page_id=MYPAGEID#slide2” or “page_id=MYPAGEID#slide3”, it will always load the first slide of my home page…

    Is there anything I’m doing wrong? or another way to do that?

    Similarly, I want to create buttons on the first slide of my home page, but no matter how I create the link in the buttons (either I put the link “#slide2” or “page_id=18#slide2”, it doesn’t work:
    – with “#slide2” as a link, the button click won’t do nothing
    – with “page_id=18#slide2” as a link, the button click will reload the page but won’t go to the slide2

    FYI, I use vertical 3D as a transition between the slides.

    Thanks for your help
    Laurent

    Hi Laurent,

    Have you tried to switch your permalinks to just post name and check if the anchor links will behave better compared to the current permalink?

    Can you please send over your site’s URL and login credentials so we can also check and test the site from our end?

    Thanks!

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.