Home / Forums / You Theme Support / Onepage navigation in menu – anchor issue

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • A customer has five pages. One page contains most of the information separated in sections. Each section has an id.

    A submenu contains custom links to each of the sections ( /page/#section-id-a, /page/#section-id-b, /page/#section-id-c etc.)

    The first click on any of the submenus works as expected. The page is called and scrolls to the section as indicated by the anchor (hash) in the url.

    Now if you click on one of the other submenu entries nothing happens. I would expect the page to scroll to the anchor indicated by that submenu. I have checked this with other themes and there it works.

    This reply has been marked as private.

    Hi Michael,

    Can you please send over your site’s login credentials so we can personally check and test this?

    Thanks!

    This reply has been marked as private.

    Hi Michael,

    Our sincerest apologies for the delayed reply.

    We have checked the issue but it looks like your site went down. We will keep monitoring this but if you can also check what’s causing it, that would be best.

    Thanks!

    This reply has been marked as private.

    Hi @mensmaximus

    The anchor links should now be working at http://ebgruppe.org/wir-ueber-uns/.

    The anchors links will only work if you use the anchor name as the link without ‘wir-ueber-uns’ on the URL.

    The best option is to have a new set of menu for the other pages and only use the one-page navigation on the ‘wir-ueber-uns’ page.

    Thanks!

    Well this is not an option because now the links dont work as long as the user is not on the wir-ueber-uns page. With other themes it is working.

    Hi Michael,

    Andy is now investigating on this. We will get back to you once we have an update.

    Regards,

    Hi Michael,

    Can you please send over your FTP login credentials? Andy will fix the theme’s code.

    Thanks!

    Hi, I dont have the ftp credentials as the customer is not sharing them with me. Please send me the revised code and I will forward it to the customer.

    Regards

    Michael

    Hi Michael,

    I will get back to you on this. I will confirm this to the developer.

    Regards,

    Hi,

    it is 6 weeks now since you promised to get back to me. My customer is starting to get angry and I have no excuses anymore. Can you fix it or not?

    Regards

    Michael

    Hi Michael,

    I sincerely apologize for the delay.

    I have made another follow-up with Andy if he can share the fix without the FTP credentials.

    Regards,

    Well this should not be a custom fix only. This is a mayor drawback and should be a general fix for the theme. So please tell Andy he already has the solutions in his other themes and ‘YOU’ should be fixed now.

    Regards

    Michael

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.