Home / Forums / You Theme Support / Onepage navigation in menu – anchor issue

Viewing 8 posts - 16 through 23 (of 23 total)
  • Author
    Posts
  • Thanks for the feedback, Michael.

    Once the fix is figured out, this should be released on the next update.

    Regards,

    The issue stems from line 1116 in acoda-script.pack.js:

    $(‘a[href^=”#”]:not([href=”#”])’).not(‘.ui-tabs-nav a, a.vc_carousel-control,.vc_tta-panel-heading a,.vc_tta-tab a,.vc_pagination-item a’).on( “click”, function()

    Changing ‘a[href^=”#”]:not([href=”#”])’ to ‘a[href*=”#”]:not([href=”#”])’ solves the problem. Unfortunately this can only be changed in the script itself and not by monkey patching as this part of the jQuery script is not defined as a plugin ($.fn).

    In addition you set the header_height hardcoded to 70 for the sticky header in function acodaAnchorScroll. As a result anchors are scrolled directly to the sticky header without any space between it. There should be a setting in the theme to allow some distance between the bottom of the header and the anchor target.

    Regards

    Michael

    Andy
    Andy
    Keymaster

    Hi Michael,

    Andy here. Unfortunately, It’s been a combination of many things that have contributed to the delay, but all of which would be an excuse. So please accept my sincerest apologies for the delay here.

    I have changed the script to href* instead of href^, so that it can detect anchor links within a URL and not just URL’s that begin with #.

    As for the stick header, I’ve changed the value to 100. That’s 70pixels for the sticky header ( which is default, unless modified ), plus the standard gap size used throughout the theme ( 30px ).

    It will be included within the next update.

    Kind regards,
    Andy

    Thank you. Good to see the changes I made myself become now official.

    Kind regards

    Michael

    This reply has been marked as private.

    Hi @thegroomingloungeonhigh

    Can you please send over your login credentials so we can personally check on this from our end?

    Regards,

    This reply has been marked as private.

    Hi @thegroomingloungeonhigh

    This should now be fixed.

    Actually, the ‘Anchor Link Name’ was not set to Academy that’s why it’s not working.

    Please check your site from your end and confirm.

    Regards,

Viewing 8 posts - 16 through 23 (of 23 total)

You must be logged in to reply to this topic.