Home / Forums / You Theme Support / Page Speed Insights rating very low

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts

  • Edwin van der Veer
    Participant

    Hi Devs,

    Thank you for developing such a wonderful that is YOU 🙂
    Visual wise it’s a pleasure to look at and there are more features than I can dream of!

    There is one question though and that is one regarding speed
    After installing the theme along with some demo content (Photography) I noticed a serious drop in speed.
    Of course there are a number of issues that underlie a problem like this. But I tried to remedy this by:

    Using Short Pixel Image optimiser to compress the images
    Installing WP Super Cache to speed up page serving
    Installing Autoptimize to streamline Java content and some more code
    (Had to disable this one again, because it would not let me load the 3D vertical animation)

    Oh yes, and on my iPad Air 2 I’m getting a ‘problem loading this website error. Reloading page’ error. Only when I switch off 3D animation for the home page, I don’t get to see this error.

    Any ideas on how to improve Page Speed scores, so that it ranks higher than around 50 (on mobile) and 70 Desktop and get rid of the ‘problem loading page error’?
    My site’s urn is http://zeeuwsdomein.nl

    Hi @caeleth

    Glad to know you are liking the theme so far.

    For the site’s speed, I tested your site on two server from Pingdom and both shows that the load time is dragged by ‘waiting’ for the server to respond to the request:
    https://tools.pingdom.com/#!/bZp40L/http://zeeuwsdomein.nl
    https://tools.pingdom.com/#!/PA9C3/http://zeeuwsdomein.nl

    Can you please try to use another theme and check if the wait time would still be dragged?

    After that, please set a non 3D page as homepage then test the site again to check if it was having 3D animation that could be dragging the load time too.

    For the error on the iPad, have you tried to disable all your plugins just to check if any of them could be causing the error or not working well with 3D pages?

    Thanks!


    Edwin van der Veer
    Participant

    Hi Edcel,

    Thank you for your quick response 🙂 (and that on a Sunday! ;))

    Did what you suggested and here are my results

    Disabled YOU and enabled Thirty Sixteen. Some improvement occurred (around 10%)
    Disabled 3D and speed went up considerably (around 20%) and it did away with the iPad error as a bonus

    Now the iPad I have has 16Gb memory and is an iPad Air 2 (pretty fast), but the memory is somewhat limited.
    The funny thing is, that on my iPhone 6s Plus, the site runs like a rabbit and there are no errors at all.

    Switching themes really is not an option, as I really like your theme (a lot!)
    And it would be a pity if I had to disable the 3D effect, as it really helps in showing my portfolio. (I think)

    Anyway, it’s obvious that the speed really improves when disabling some features.
    Another option for me would be to change my hosting package. (It is dedicated by the way and not shared)
    But stepping up could solve the server problem I guess.

    Any suggestions to what to do next from your point of view?

    Cheers!

    Edwin


    Edwin van der Veer
    Participant

    Update:

    I altered the following in the Theme’s settings

    Disabled the 3D effect altogether. Enabled padding (looks better)
    and enabled ‘snap scroll’ instead of the 3D effect (speed increase)
    Changed 4 columns into only one and Zoom effect+text

    This takes care of the problems on my iPad (no more errors), makes my
    portfolio look good and gives a slight speed increase as an added bonus 😉
    It’s not perfect, but for the moment it’s the best I can squeeze out of it 😉

    The 3D effect is a lot nicer, but if it slows down the site, then it’s better left alone (at least in my case)

    To gain some more speed I use WP Super cache (mod rewrite set to ON) and Autoptimize (JAVA code streamliner)
    Pingdom now gives me a performance grade of 86 (Stockholm server) which isn’t bad at all.

    Leveraging browser caching could be improved (according to Pingdom) Any ideas how to pull that off?

    Thanks 🙂

    Edwin

    Andy
    Andy
    Keymaster

    Hi Edwin,

    It’s strange that disabling the 3d and enabling Snap would have any affect. They use the same JS file, so there is no extra load.

    See the settings below that I use for autoptimize – :

    Also, you need to enable a few things on your server. If you have access to the .htaccess file on your server, add the following to the bottom of it:

    <IfModule mod_deflate.c>
      # Compress HTML, CSS, JavaScript, Text, XML and fonts
      AddOutputFilterByType DEFLATE application/javascript
      AddOutputFilterByType DEFLATE application/rss+xml
      AddOutputFilterByType DEFLATE application/font-woff2
      AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
      AddOutputFilterByType DEFLATE application/x-font
      AddOutputFilterByType DEFLATE application/x-font-opentype
      AddOutputFilterByType DEFLATE application/x-font-otf
      AddOutputFilterByType DEFLATE application/x-font-truetype
      AddOutputFilterByType DEFLATE application/x-font-ttf
      AddOutputFilterByType DEFLATE application/x-javascript
      AddOutputFilterByType DEFLATE application/xhtml+xml
      AddOutputFilterByType DEFLATE application/xml
      AddOutputFilterByType DEFLATE font/opentype
      AddOutputFilterByType DEFLATE font/otf
      AddOutputFilterByType DEFLATE font/ttf
      AddOutputFilterByType DEFLATE image/svg+xml
      AddOutputFilterByType DEFLATE image/x-icon
      AddOutputFilterByType DEFLATE text/css
      AddOutputFilterByType DEFLATE text/html
      AddOutputFilterByType DEFLATE text/javascript
      AddOutputFilterByType DEFLATE text/plain
      AddOutputFilterByType DEFLATE text/xml
    
      AddType application/font-woff2 .woff2
    
      # Remove browser bugs (only needed for really old browsers)
      BrowserMatch ^Mozilla/4 gzip-only-text/html
      BrowserMatch ^Mozilla/4\.0[678] no-gzip
      BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
      Header append Vary User-Agent
    </IfModule>
    
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType image/jpg "access 1 year"
    ExpiresByType image/jpeg "access 1 year"
    ExpiresByType image/gif "access 1 year"
    ExpiresByType image/png "access 1 year"
    ExpiresByType text/css "access 1 month"
    ExpiresByType text/html "access 1 month"
    ExpiresByType application/pdf "access 1 month"
    ExpiresByType text/x-javascript "access 1 month"
    ExpiresByType application/x-shockwave-flash "access 1 month"
    ExpiresByType image/x-icon "access 1 year"
    ExpiresDefault "access 1 month"
    </IfModule>

    The site looks great btw!


    Edwin van der Veer
    Participant

    Hi Andy,

    Thanks for getting back on this so soon 🙂 Appreciate it a lot!

    Yes, you’re right. Snap wouldn’t help much in getting faster speeds, but I thought disabling 3D for the Home page would?
    But then again, JAVA is not really my ‘cup of tea’ so to speak 😉 So thank you for pointing that out 🙂

    I’m going to implement the code you provided and insert it into the htaccess-file. As far as I understand it, it means using Gzip compression to speed up the process, right? That will help 🙂

    Been a fan of Dynamix for many years and that’s not likely going to change with YOU 🙂
    Thanks again and I will let you know how this plays out 🙂

    Cheers!

    Edwin


    Edwin van der Veer
    Participant

    Hi Andy,

    Just implemented the code
    Had to alter “<” and “>” before and after the “IfModule mod_deflate.c” code and change it into “<” and “>”
    After that it worked just fine 🙂

    I had the following code already in place:

    “<IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType image/jpg "access 1 year"
    ExpiresByType image/jpeg "access 1 year"
    ExpiresByType image/gif "access 1 year"
    ExpiresByType image/png "access 1 year"
    ExpiresByType text/css "access 1 month"
    ExpiresByType text/html "access 1 month"
    ExpiresByType application/pdf "access 1 month"
    ExpiresByType text/x-javascript "access 1 month"
    ExpiresByType application/x-shockwave-flash "access 1 month"
    ExpiresByType image/x-icon "access 1 year"
    ExpiresDefault "access 1 month"
    </IfModule>”

    After inserting the code my performance grade (at Pingdom) went up to A 93!

    So thank you there! (and for the compliment regarding the site btw; but that is partly your doing ;))

    Thank you very much again 🙂

    Edwin

    Hi @caeleth

    Glad to know Andy’s advice was able to speed up the site and I am also glad he personally handled the ticket. 🙂

    Don’t hesitate to contact us if you run into other issues.

    Regards,

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.