Home / Forums / DynamiX Support / Parallax problem on mobiles

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts

  • Imagina MÁS
    Participant

    Hello I’ve been looking through all the posts already published on the forum but none of the things I’ve found helped me. I’m thinking of changing the home page of our NGO and I would like to give parallax a go since it’s very outstanding. The problem is that when testing it on mobile devices the images and the text does not always fit the screen. At first I thought ti was because there was far too much text, si I tried by using just small sentences. One part did work but the other one not…

    Not sure what I’m doing wrong.

    I saw on one of your posts that the CSS code below should be included on the mobile CSS, but did not work either.
    .row.custom-row.parallax .parallax-wrap { word-break: normal !important;}

    The page affected is http://www.imaginamas.org/inicio/imagina-mas-ong-de-salud-sexual-vih-y-prostitucion (you will need to enter the password 123 since it’s still private) thanks

    • This topic was modified 1 year, 7 months ago by  Imagina MÁS.

    Imagina MÁS
    Participant

    Sorry I forgot one more thing, How can I get rid off of the blank frame between the header and the first image? thanks

    Andy
    Andy
    Keymaster

    Hi,

    The image will not fit because of the way parallax works – it covers the entire screen without changing the ratio of the image and it’s center aligned, so you will always see the center of the image on mobile and it will look zoomed in. Do you have a screenshot of the text not displaying?


    Imagina MÁS
    Participant

    Hi Andy! thanks a lot for your quick reply and for clarifying me how parallax works… Not sure why but I checked now again and the text appears properly… 🙂 thanks thanks!

    btw do you know how can I get rid off the blank frame between the header and first image? I tried with no-margin-top but did not work. I have the same problem with the rest of the pages, not only that one.. I think is the area where the widgets appear (if selected) but I don’t have that option enabled.

    thanks a lot!

    Andy
    Andy
    Keymaster

    Try adding -20px to the first row via Edit Row > Design Options > Top Margin. The second thing is that it appears that sub-header is still showing. Please disable the Title and Breadcrumbs via the Page Options > Page Config.

    I hope that helps.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.