Home / Forums / DynamiX Support / PHP closing tag visible on top of every page

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts

  • Ulf Kohlmorgen
    Participant

    I just updated from 2.8.4 to 2.8.6. in the usual way but after doing this a PHP closing tag (?>) is displayed in the upper left corner on every page.

     Looking at the source code of such a page reveals this:

    ?>

    <!DOCTYPE html>

    <html dir="ltr" lang="de-DE">

    <head>

    Because of this I can't even visit e.g. the Header Settings page of DynamiX because the content of that page shows php code instead of html elements.

    Any hints from where this closing PHP tag comes from? 

    Andy
    Andy
    Keymaster

    Hi,

    That definitely shouldn't be happening – it doesn't with the standard theme, either something hasn't uploaded properly or a plugin is causing an issue. I'm guessing not all files have uploaded properly. 


    Ulf Kohlmorgen
    Participant

    I've uploaded the complete contents of the DynamiX folder (with overwrite all) and all files that are different from my "old" v2.8.4 DynamiX-Child folder. Repeated this process today and deactived all plugins (with no exception), too.

    Cleared the browser cache and reloaded the site: Still the PHP ending tag in the top left corner 🙁

    Andy
    Andy
    Keymaster

    That seems really strange – can you post a link and I'll see if I can spt anything but I've double checked the normal files and it definitely doesn't do that. 


    Ulf Kohlmorgen
    Participant

    http://www.pc-problemhilfe.de

    Thanks in advance 🙂

    Andy
    Andy
    Keymaster

    Strange – is there anything in the HTML field? DynamiX -> Header Settings -> Custom HTML?


    Ulf Kohlmorgen
    Participant

    No, there isn't, sorry.

    I've made three screenshots (in this case: Chrome browser) and put them into one to show how weired such a page looks:

    http://i.imgur.com/UynWk.jpg

    I tried to use a screenshot tool for the IE but had to recognize that I can't even open this link in that browser. This is the link that I've used:

    http://www.pc-problemhilfe.de/wp-admin/admin.php?page=droppanel

    And this is the output of the browser:

    ?>

    Warning: Cannot modify header information – headers already sent by (output started at /kunden/275617_29328/webseiten/wordpress/wp-content/themes/DynamiX/custom-functions.php:3) in /kunden/275617_29328/webseiten/wordpress/wp-includes/pluggable.php on line 934


    Ulf Kohlmorgen
    Participant

    I've just installed v2.8.7 and the problems are gone….

    Let's hope I don't have that problem again 🙂

    Andy
    Andy
    Keymaster

    No idea why that was there, I'm glad it's sorted though. 

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.