Home / Forums / ePix Support / Portfolio Issue

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts

  • Jake Browne
    Participant

    Hey, just installed the theme and have been playing around with a few things, but have found the documentation on Portfolio pretty lacking. I’m trying to set up each portfolio as a full screen gallery. I’ve uploaded the media, then created a slide set, then assigned that slide set to the portfolio page. I’m guessing I’m simply doing it wrong?

    FWIW, when I attempt to “View page” after saving, it’s saying that it can’t find the page.

    Thank you!

    EDIT: Client needs to keep everything confidential so if you need a link for information, please provide a private contact option.


    Tom ( Support)
    Keymaster

    Hi Jake,

    Are you trying to set up Portfolio pages or are you using Portfolio posts as images to build up a gallery? What are your settings for Permalinks under Settings Permalinks?

    Please can you reply with your login details so I can take a further look into this? Please set your reply to private also.

    Kind regards,
    Tom


    Jake Browne
    Participant

    Resolved – needed to alter my permalink structure. Thank you.


    oliver
    Participant

    Hi Tom is there any documentation on Portfolio page i can read up on?


    Tom ( Support)
    Keymaster

    Hi Oliver,

    There isn’t any documentation on the Portfolio page as it is works the same as a Post. The portfolio post type is there so that users can have a separate Portfolio type section of their site to normal blog posts. Portfolio posts will be on a /portfolio URL too.

    Is there anything else you need to know?


    Fabio
    Participant

    Hi Tom,

    I’m going to jump in this thread instead of creating a new since I have an issue with the portfolio as well.
    I’m trying to create a gallery that links to different pages per image and I would like to customize those pages for example with a gallery inside, some videos, custom text (basically a full custom layout). Since as you mentioned the portfolio works like posts, i can’t use the Visual composer and the only way I have found to add a gallery is on top of the post with “Add gallery” feature.
    This way though they images appear always at the top before any other element and I also cannot remove the Featured Image.

    Is there a work around for this?
    One way I found is to use normal pages instead of the portfolio but this way I lose the filtering possibility, any other way to accomplish this?

    Thanks you


    Tom ( Support)
    Keymaster

    Hi Fabio,

    You can enable Visual Composer within these pages by going to Settings > Visual Composer > Check Portfolio.


    Fabio
    Participant

    Hi Tom,

    thank you very much, that did the trick.
    To removethe Featured image I had to apply a custom css fix, but I assume that’s the way to do it since there is no specific option for it.

    Thanks again, once more happy to give you 5 stars 🙂


    Tom ( Support)
    Keymaster

    Hi Fabio,

    You can remove the featured image through Appearance > Theme Options > Blog > Post Content but this will do it for the Posts too.

    Thats great, thank you 🙂


    Fabio
    Participant

    Hi Tom,

    you’re right, but as you said that would remove it from all the posts and I want to be able to disable it only on some pages.
    I’ll test a bit the fix I did with the css and see if it gives any other issue.

    Thanks anyway.


    Jay
    Participant

    Hi,

    I basically have the same issue. While Portfolio is in fact a Post, it’s still meant to be used separately. I want the Featured Image to be shown in the Blog (Title + Featured Image + Excerpt), but not in the Portfolio, since I already have a Gallery up there.

    Hiding the image with CSS on the Portfolio page would work, but far from ideal, since the image is still being loaded. Any ideas how to solve this?

    Thanks for an otherwise awesome theme!

    Jay


    Tom ( Support)
    Keymaster

    Hi Jay,

    This is an option that Andy is looking to build into the next update but I cannot put a date on it. I recommend hiding it using CSS.

    Change the page id for your own page id. Right click > View Source > Search for page-id- > copy the id and paste into the CSS.

    .page-id-111 .gridimg-wrap {
    display: none;
    }
    

    Hope this helps.

    Kind regards,
    Tom


    Jay
    Participant

    Hi Tom,

    Thanks for your reply. Hiding it with CSS is sufficient for now. I’ve used the class .single-portfolio instead of using the page-id class.

    This is what I use now for every single Portfolio page.
    .single-portfolio #primary-wrapper .mediawrap { display:none; }


    Donato Fernández
    Participant

    Great solution Jay. Thanks!!!

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.