Home / Forums / DynamiX Support / Problem with new Dynamix update

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • Joseph Priser
    Joseph Priser
    Participant

    having a problem with new update.
    When I went to update I got this:
    Parse error: syntax error, unexpected T_FUNCTION in /home/content/t/o/m/tommytodd/html/website/wp-content/themes/DynamiX/lib/inc/sub-functions.php on line 166
    I then did 3 things. I took the 4.0.8 version of that file and uploaded it and everything worked again.
    Only this time the visual composer changed my front page elements and some elements on my portfolio pages as the bottom row under see more portfolios is now vertical as to horizontal which was not that way before. On the front page I get the same as items are not aligning up horizontal.
    I then reloaded a older version via ftp and everything worked fine, but still same problems as above.
    I then renamed the old version theme folder Dynamix_current then uploaded the newest version of Dynamix to a theme folder called DynamiX and I get the parse error.
    Any ideas. This has happened with 2 different sites.

    Andy
    Andy
    Keymaster

    Hi Joseph,

    This is going to be the next version of the sub-functions.php, please test it on your server to see if it resolves the issue.

    Unzip and replace DynamiX/lib/inc/sub-functions.php with – http://help.themeva.com/tmp/dynamix/sub-functions.php.zip

    Joseph Priser
    Joseph Priser
    Participant

    Worked like a charm and every page came back to the right setup.
    Thanks Andy!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.