Home / Forums / ePix Support / Problem with Visual Composer

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts

  • Fabiano de Bruin
    Participant

    Hi,

    After I installed the visual composer, this warnings start to be show in all pages… also in the wp-admin

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 71

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 73

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 71

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 73

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 71

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 73

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 71

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 73

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 71

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 73

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 71

    Warning: Illegal string offset ‘param_name’ in /home/fabia951/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 73

    What can I do do solve this??

    Thanks!


    Fabiano de Bruin
    Participant

    I install via the purple message that appears within the admin of WordPress…

    Andy
    Andy
    Keymaster

    Hi,

    I’ve already mentioned this to the Visual Composer developers before and thought they had implemented the fix, however it turns out they haven’t. The fix for this warning is below:

    Locate: /wp-content/plugins/js_composer/composer/lib/mapper.php

    Unzip and Replace With: http://help.themeva.com/tmp/mapper.php.zip


    Fabiano de Bruin
    Participant

    Hi Andy!

    Thanks!!! It works fine! Now everything is running well!


    jerry
    Participant

    Perfect! :D!


    Jenni Christopher
    Participant
    This reply has been marked as private.

    Jenni Christopher
    Participant
    This reply has been marked as private.

    Peter Cane
    Participant

    I am have a similar problem, the home page shows this:

    Warning: DOMDocument::loadXML() [domdocument.loadxml]: Empty string supplied as input in /home/content/12/9716812/html/wp-content/themes/ePix/lib/inc/classes/slideset-class.php on line 102

    Warning: Invalid argument supplied for foreach() in /home/content/12/9716812/html/wp-content/themes/ePix/lib/inc/classes/slideset-class.php on line 106

    Warning: array_unique() expects parameter 1 to be array, null given in /home/content/12/9716812/html/wp-content/themes/ePix/lib/inc/classes/slideset-class.php on line 122

    Warning: asort() expects parameter 1 to be array, null given in /home/content/12/9716812/html/wp-content/themes/ePix/lib/inc/classes/slideset-class.php on line 123

    Warning: DOMDocument::loadXML() [domdocument.loadxml]: Empty string supplied as input in /home/content/12/9716812/html/wp-content/themes/ePix/lib/inc/classes/slideset-class.php on line 204

    Fatal error: Call to a member function getElementsByTagName() on a non-object in /home/content/12/9716812/html/wp-content/themes/ePix/lib/inc/classes/slideset-class.php on line 210

    Is the repair the same?

    Thanks
    Peter.


    Tom ( Support)
    Keymaster

    Hi Peter,

    It looks like you need to update WordPress and ePix.

    A new update has been released for ePix which contains the latest version of Visual Composer too.

    For more information on updating the theme, please see here.

    Once updated, you can update VC by go to Plugins > Deactivate VC > Delete it > Appearance, Install Plugins, click install Visual Composer > You should now have the latest version.

    Then reset your browser cache and websites cache (if you have a cache plugin installed).

    Hope this helps.

    Kind regards,
    Tom


    Peter Cane
    Participant

    Hi Tom I’ve updated WordPress, although it was up to date with Ver 4, no improvement. I previously installed Envato and its currently not saying I need an update. If it doesn’t show I need an update, how do I do an update to Epix?


    Peter Cane
    Participant

    Hi Tom ok I deleted deactived VC and deleted it, after going to appearance, install I got this:

    The plugin does not have a valid header.
    Downloading install package from /home/content/12/9716812/html/wp-content/themes/ePix-Child/plugins/js_composer.zip…

    Download failed. A valid URL was not provided.

    What do you think?
    P.


    Peter Cane
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Peter,

    You are currently using ePix 1.0.7 which is quite an outdated version of the theme. The current version is 1.2.

    Once updated, you will need to switch back to the core theme, update VC, then switch back to the child theme.

    The error above is coming from a gallery that does not have a datasource or slide set selected. I recommend checking the galleries on the page.

    If you have entered in the correct details to the Envato toolkit plugin, it should show all of the themes you have purchased and you can update from there.

    Hope this helps.
    Tom

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.