Home / Forums / DynamiX Support / Problems with Shortcodes

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts

  • Maria Colaluca
    Participant

    I'm having problems with the shortcodes. I'm using the column shortcode with a list shortcode nested inside each column. When I preview the page, the second column doesn't line up with the first along the top.

    Also, I tried using the tabs shortcode, but it just marks the headline with a bullet, instead of creating a tab like in the demo.

    I went through the troubleshooting section, and I've verified that I am using PHP 5 and I've installed the theme correctly. 

    Please see my attached screencaps for reference:

    Andy
    Andy
    Keymaster

    Hi,

    It's because WordPress is placing HTML tags where they aren't wanted. To eliminate this you have to make sure the shortcodes are next to each other e.g.

    [shortcode for column one] [shortcode for column two] 

    They are next to each – if you place a space, or a carriage return it will place HTML tags in. 


    Maria Colaluca
    Participant

    I'm use the html editor when I insert and edit the shortcodes; I removed the spaces to see what would happen and this is what resulted:


    Maria Colaluca
    Participant

    Here's my code:

    Columns

     

    [two_columns  border="border"]GET INSPIRED<a href="http://www.ams-sites.com/sites/POT/wp-content/uploads/2011/07/dvd.jpg"><img src="http://www.ams-sites.com/sites/POT/wp-content/uploads/2011/07/dvd.jpg&quot; alt="Power On Texas DVD" title="Power On Texas DVD" width="123" height="119" class="alignright size-full wp-image-112" /></a>

    <ul>

    <li>See what very different 7 districts are doing to POWER ON</li>

    <li>Discover how one Education Preparation program is changing the paradigm</li>

    <li>Why POWER ON? Why now?</li>

    <li>Go deeper – watch the full documentary and explore the resource guide</li>

    </ul>

    [/two_columns][two_columns_last  border="border"]GET STARTED<a href="http://www.ams-sites.com/sites/POT/wp-content/uploads/2011/07/do_thumb.jpg"><img src="http://www.ams-sites.com/sites/POT/wp-content/uploads/2011/07/do_thumb.jpg&quot; alt="Do" title="Do" width="130" height="204" class="alignright size-full wp-image-113" /></a>

    <ul>

    <li>Evaluate your district's needs</li>

    <li>Make a plan to begin</li>

    <li>Connect with people who are POWERED ON and learn from their journey</li>

    <li>Make the POWER ON TEXAS commitment and share your excitement now</li>

    </ul>
    [/two_columns_last] 

     

    Tabs

    [tabswrap][tabhead_last id="1"]GET INSPIRED[/tabhead_last][tab id="1"]Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nullam massa urna, ultrices et ornare at, bibendum eu tortor. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Mauris convallis ante aliquam risus dignissim tincidunt placerat leo ultrices. Phasellus adipiscing ante vel nulla tristique eu interdum odio ultricies. Sed accumsan mollis pretium. Quisque sapien est, gravida vestibulum facilisis sed, porta nec lectus. In sagittis rhoncus elementum. Aliquam rhoncus mauris convallis ipsum dignissim eleifend. Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Nullam tempor lacus at mauris malesuada ut gravida purus porttitor. Pellentesque urna ligula, viverra laoreet blandit ut, malesuada at sapien.[/tab][/tabswrap]

    Maria Colaluca
    Participant

    Well that didn't work. Here's screencaps of my code:

    Columns

    Tabs


    Maria Colaluca
    Participant

    I'm still working through the problem, and I'm just posting my progress in case someone else is following this thread.

    I figured out the columns. I needed to insert the titles and lists into the content fields of the columns shortcode generator without spaces. Adding the list shortcode to the columns shortcode in the HTML editor won't work. I tried removing spaces from the list shortcode inside the content area of the tabs shortcode, but it's still not working. Here's screencaps of what it looks like now:

    and the code:

    Andy
    Andy
    Keymaster

    Unfortunately the only sure way to get around this is to disable the WordPress auto formatting function. You can do this with a plugin – one is ps disable auto formatting – that will stop wp adding extra code


    Maria Colaluca
    Participant

    I just figured it out. I was using one tab for the shortcode. I set it to 3 tabs, and it started working fine. Thank you for your time and help!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.