Home / Forums / DynamiX Support / Recent Posts first 55 words on Home Page not displayed using Visual Composer

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts

  • Steve Martin
    Participant

    Hi there, Just wanted to highlight a potential bug when using the Visual Composer for creating posts. If you use a Recent Posts Element from Visual Composer on the Home Page of your website and try to show say the first 55 words it does not display anything just the Title and Read More link. However if you change back to Classic Editor and then re-do everything the post will show on the home page with the first 55 words displayed and also any images.

    I really like using the Visual Composer but there is definitely a bug when using Visual Composer Recent Posts Element on a Home Page.

    I can shown the URL if required

    Andy
    Andy
    Keymaster

    Hi Steve,

    Because the excerpt is reading the contents, it see all of the code. A couple of solutions to this:

    1. is to create an excerpt for those posts ( Post > Screen Settings > Check Excerpt > Scroll to Excerpt ) > Goto Settings Excerpt and ensure “Generate excerpts even if a post has a custom excerpt attached.” is unchecked.

    2. Goto Settings > Excerpt and uncheck “Don’t remove any markup” and then check the content you want. e.g. a, p etc.


    Steve Martin
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Yes, the second option will allow you to keep images if you select the img tag.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.