Home / Forums / DynamiX Support / Requesting Immediate assistance on enabling Twitter on plugin generated pages

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts

  • Anonymous

    Hi ,

    I’m looking for immediate assistance for enabling the Twitter feeds on the pages that we don’t have control on. I mean those pages that are generated by plugins.

    http://cloudchowk.com/future/career/ Twitter feeds in the footer of this home page and other similar pages are enabled by “Enable twitter below page content” settings in the page’s admin edit panel.

    http://cloudchowk.com/future/career/net-database-architect/

    http://cloudchowk.com/future/career/apply/320/ while the latter 2 links doesn’t tweet them. I’m using Job Manager plugin. But I believe the code that needs attention is with the theme’s function which validates the setting. I’m not that good at php.

    I would be so grateful if anyone could help me in anyway or give me a hint. I’m nearing the deadline to make the site live.

    Please help me where/what/how to.

    Many Thanks.

    Andy
    Andy
    Keymaster

    There doesn’t appear to be any errors being thrown – because it’s  in the footer it should work on every page, I’m not sure why it’s picking and choosing. Have you asked the plugin developer?


    Anonymous

    Its because you have validated whether the “Enable Twitter” option(page’s admin edit panel) is enabled on each page.

    So I added

    <div id="tweet_content">
    <?php require CWZ_FILES .'/inc/twitter.php'; // Call Twitter Template ?>
    </div>

    to the below pages the following way:

    header.php( right above the </head> ),

    page.php( before <?php get_sidebar(); ?> )

    But it doesn’t seems to work. I didn’t contact the plugin developer since I strongly believe there is nothing for them to do with this. I guess the page is missing the jQuery! I may be even wrong. Let me work that way and let you know. Thanks for coming to help sooner. Great theme. Great support. Cheer up!!


    Anonymous

    I think there is no point in my previous statement about missing of jquery. The code calls the whole twitter template, right? Why should the page again require jquery when its already added in twitter.php?

    And May I know what does this code mean?

    <?php if(get_option('priority_loading')=='enable') { ?>

    Does it have anything to do with affecting the display of tweets in other pages?

    Please kindly help. Thanks


    Anonymous

    Hi Andy I read about the functionality of priority_loading setting and tried adding headjs loader manually into footer.php. But it didn’t work even that way.

    I think the problem is again due to the jQuery priority setting that was in DynamiX 2.8.9.

    I hope you remember the problem I had earlier with this setting as we discussed here: http://help.themeva.com/groups/dynamix-support/forum/topic/droppanel-trigger-not-working-sometimes/

    I checked the code on my part and its clean as you too see there is no error being thrown. And meanwhile I’m messaging you privately the userid password for my site. Please kindly take a look at it and help me.

    Many Thanks


    Anonymous

    No doubts at all Andy. Its very clear that the problem is with the JQuery priority setting that was initially in DynamiX 2.8.9. I get the same list of jquery errors like I received a month ago. And I’m sure its only you who can get me some help.

    Kindly tell me how to revert the setting back like you did for me the last time. I will be all by myself if I encounter the same problem again in near future. Sorry for bothering you now. I have no other go.

    Here is a link to the firebug error report: http://img715.imageshack.us/img715/6342/cloudchowknewerror.png

    But chrome and IE are not loading the site itself. Do you have any idea about that?

    Many Thanks.


    Anonymous

    I think i’m almost there! Is this the code that’s requiring attention? I may be even wrong. If yes, I’m not sure what to do with it.

    INSERT INTO `wp_options` (`option_id`, `blog_id`, `option_name`, `option_value`, `autoload`) VALUES(416, 0, 'priority_loading', 'enable', 'yes');

    Please kindly help. Thanks

    Andy
    Andy
    Keymaster

    Hi,

     

    Try modifying this line in DynamiX/footer.php

     

    <?php
    if(TWITTERUSR!=”” && $DYN_twitter!=”none”) {
    if($DYN_twitter!=”) { ?>
    gettweets(‘<?php echo TWITTERUSR; ?>’,'<?php if(TWITTERNUM) {echo TWITTERNUM;} else { echo “5”;} ?>’);

    <?php }
    } ?>

     

    to

     

    <?php
    if(TWITTERUSR!=””) { ?>
    gettweets(‘<?php echo TWITTERUSR; ?>’,'<?php if(TWITTERNUM) {echo TWITTERNUM;} else { echo “5”;} ?>’);

    <?php }  ?>


    Anonymous

    That greatly helped. Thanks.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.