Home / Forums / DynamiX Support / Responsive Layout not working at all

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • artinbox
    Participant

    hi, (sorry for my english)

    Your template it’s really nice but i have an big issue with, i had thinkink it’s the other plugin have the conflit with dynamix so i just install a fresh version of wordpress and dynamix 5 last version

    i have always the same problem,if you look on this page and if you try to shrink to page to have an mobile size i have set to have 2 collumn on the mobile size but i have only one collumn :
    http://www.gmacommunication.com/dev/exemple/
    the problem seems to be on your template you use the css “one two three etc… ” on my page i have “six” i’ts overwrite the bootstrap reponsive ” vc_col-xs-6″ when you set the responsive option like the youtube video below

    i should be work like this but it’s not working.
    https://www.youtube.com/watch?v=_C1SE2Cj-4k

    can you help me to fix this ?

    Have nice day
    Best Regards
    Fred

    • This topic was modified 2 years, 1 month ago by  artinbox.
    Andy
    Andy
    Keymaster

    Hi Fred,

    Unfortunately Visual Composer doesn’t make use of the Foundation framework properly. I’m looking into this to see if I can improve it. Thank you for pointing it out.


    dpotuznik
    Participant

    hi,

    your theme is very nice, thank you !
    i have same issue,
    it’s really annoying, impossible to create a mobile version that works properly. it’s a pretty crucial element for me.

    a chance to fix it soon ?

    in the meantime a wish you a beautiful day.
    Daniel

    Andy
    Andy
    Keymaster

    Leave this with me, I’m currently addressing it for the next version 🙂

    Andy
    Andy
    Keymaster

    Hey Guys,

    It looks like VC introduced their own grid system a while back ( I hadn’t noticed this ). That means I no longer have to use the theme version.

    To get the above working properly, please remove the following line of code from DynamiX/lib/inc/sub-functions.php

    		if ($tag=='vc_column' || $tag=='vc_column_inner')
    		{			
    			if( WPB_VC_VERSION >= '4.3' )
    			{
    				$class_string = preg_replace('/vc_col-sm-(\d{1,2})/e', "numberToWords($1,'vc')", $class_string );
    			}
    			else
    			{
    				$class_string = preg_replace('/vc_span(\d{1,2})/e', "numberToWords($1,'vc')", $class_string );
    			}
    		}

    That should do it.


    dpotuznik
    Participant

    thank’s a lot!!

    i going to try tomorrow and let you know if it working.
    Thank you very much.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.