Home / Forums / DynamiX Support / RSS feed broken by Advanced Excerpt plugin

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts

  • Marcus Cake
    Participant

    My RSS feed plugin was broken. I disabled Advanced Excerpt and the RSS Feed worked again. I use WordPress 3.8.1 and the current version of Dynamix. Advanced Excerpt has not been updated in two years.

    I know Themeva don’t maintain this plugin, but the template does require/suggest that it is installed.


    Marcus Cake
    Participant

    Advanced Exerpts may also be breaking the recent_post shortcode … it seems to insert a large amount of the excerpt in the first post in the list if recent posts.


    Tom ( Support)
    Keymaster

    Hi Marcus,

    Exactly which RSS feed plugin are you having issues with? I would like to test it on my own server to see if we can get things working. The plugin hasn’t been updated as it hasn’t needed to be as of yet.

    Do you have an example to the recent post shortcode? Please set your reply to private and provide your URL/login details so I can take a further look for you.

    Kind regards,
    Tom


    Marcus Cake
    Participant

    The feed that is broken is the /feed and /feed/atom (those are the only ones I have tested).

    If you add the except option (text/image I think) that puts an except into the recents posts listing. That should be enough for you to test.

    Access to my server. I have removed the “excerpt” display from all recent posts listings. There is nothing to see on my server (regarding recent posts).

    I’ll see if I can provide a place for you to have a look at the feed error. Can you see if you can reproduce the error with your test site?

    I can provide you access to my admin area as suggested. However, I run Cloudflare which adds a degree of complexity to provide you with admin access for the purposes of debugging (ie I would need to turn Cloudflare off). Would you mind using your test site to confirm the RSS feed works (with Advanced Excerpt activated)? Could you also check recent posts (with excerpts) work on your test site. That way, we can atleast confirm my conclusion that Advanced Exceprts is causing the problem on a clean site.


    Tom ( Support)
    Keymaster

    What exactly is the issue with the RSS feed? If you go to http://dynamix.themeva.com/feed/, the RSS feed displays properly. If yours is not like this, a plugin may be conflicting with things. I recommend de-activating each of your plugins one-by-one to find one that may be conflicting.

    I am tested the Recent Posts Plugin (not the WP one) within Visual Composer on my dev site and I can confirm it works perfectly. The excerpt is displaying correctly etc. I have the Advanced Excerpts plugin activate and the latest version of DynamiX.

    There must be something up with your install or site for yours to act differently.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.