Home / Forums / DynamiX Support / Sidebar and footer changes after updates

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts

  • The Denovati Group
    Participant

    We have three sites on which we use DynamiX, and the same problem has occurred with each.

    Previously there was a vertical divider between the main body of a page and the sidebar, and the header at the top of the sidebar created a certain level of padding between the bottom of the header and the top of the page. We had actually added custom CSS to line up the top of the body with the top of the sidebar.

    Now there is no vertical divider and the top of the sidebar is much closer to the header, so they’re out of alignment again. Examples:

    http://denovati.com/2014/02/social-media-sophistication
    http://arts-festival.com/silent-auction

    Also note that in the second example there are weird bullets/dots appearing in the sidebar widgets too.

    Is there something we should have tweaked after updating everything?

    Andy
    Andy
    Keymaster

    Hi,

    For the sidebar to header padding, you can add this to Appearance > Theme Options > Customize > Custom CSS:

    .sidebar.columns {padding-top:21px;}

    As for the sidebar divider, this was purposely removed due to the dating look the shadow gave.

    If you wanted a line divider back in, you could add something like:

    .sidebar.columns {
    border-left: 1px solid #e9e9e9;
    }


    The Denovati Group
    Participant

    Thanks, Andy. I agree the shading looked a bit dated, but I do think a divider is helpful. The code you provided works well for right-hand sidebars, but not for left-hand sidebars like on http://arts-festival.com/2015/01/children-youth-sidewalk-sale-rule-change/.

    And what about the funky dots showing up on the arts-festival.com sidebar, like http://arts-festival.com/silent-auction? Any thoughts on those?

    Courtney


    The Denovati Group
    Participant

    Found the reason for the funky dots – there was a stray </div> in one of the widgets! Now that’s fixed… 🙂

    Andy
    Andy
    Keymaster

    Ok, change this CSS:

    .sidebar.columns {
    border-left: 1px solid #e9e9e9;
    }

    To this instead:

    .sidebar.columns.right {
    border-left: 1px solid #e9e9e9;
    }

    .sidebar.columns.left {
    border-right: 1px solid #e9e9e9;
    }


    The Denovati Group
    Participant

    Thanks, Andy – you’re the best! Happy weekend!

    Andy
    Andy
    Keymaster

    You’re welcome, have a great weekend!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.