Home / Forums / ePix Support / Site incredibly slow

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts

  • Stephanie Hitchcock
    Participant

    Hi.. I’ve updated my theme to ePix and while i love the look and feel of it it’s make my site incredibly slow. If i change to a different theme with the same content it is fine. Any ideas?
    Site is stephhitphotos.co.uk if you want to see what i mean..

    Thabnks


    Dan Rowe
    Participant

    Same issue here. My galleries, which I love the look of, take as much as 30 seconds to even go to the page then another couple of seconds to load the images. The time is the same whether tested on a 50Mb connection or a 3Mb DSL line.


    Tom ( Support)
    Keymaster

    Hi,

    This will be down to your server loading speed. If you check the demo site speed test here and your site here, you will see there is a difference in the server time.

    There is a 2.6 second wait from your server on your site which will be the cause of this wait.

    Check if you have Flickr enabled within Appearance > Theme Options > General > Flickr.

    Your server looks like it is having a lot of issues as it it now showing Service Unavailable.

    Kind regards,
    Tom


    Tom ( Support)
    Keymaster

    Hi,

    On closer inspection, it seems the images you have uploaded are excess of 5000px wide, which is way too large for any website or server to handle. I recommend using images up to 2000px wide for the fullscreen slider and smaller for other galleries.

    Kind regards,
    Tom

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.