Home / Forums / ePix Support / Slider Rev Pictures not showing

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts

  • hafeezsaeed
    Participant

    Hi

    On my front page I have a slider at the top with around 10 images using slider revolution plugin.
    More than half of these images come out blank when you load the website. I have reduced the file sizes to 1mb or even less for the pictures but still the issue is there. Please could you take a look?

    Website: http://hafeezsaeed.com

    Many thanks

    Hi @hafeezsaeed

    Can you send over your login credentials so we can check this from our end?

    Regards,


    hafeezsaeed
    Participant
    This reply has been marked as private.

    Hi @hafeezsaeed

    As I checked, your site is actually pretty large with a total page size of 15MB. A well-optimized site is actually only around 3MB, but it is understandable for your site because of the gallery but you need to optimize the site further.

    For example, on your gallery, you are using a large images, and a great example is: http://hafeezsaeed.com/wp-content/uploads/2016/08/Candle-Ambience.jpg

    This image is 1MB and its dimension is overkill to the ‘container’ you are placing it on in the gallery since you do not really need the image that large.

    And it looks like most, if not all, images on the homepage slider are over 1MB and really huge. Here are examples:
    http://hafeezsaeed.com/wp-content/uploads/2016/08/Neighbourhood-Watch.jpg
    http://hafeezsaeed.com/wp-content/uploads/2016/08/Morrocan-Pillar-Calligraphy.jpg
    http://hafeezsaeed.com/wp-content/uploads/2016/08/Charles-Palace.jpg

    Optimizing and minimizing the images on the gallery should help speed up the site, specially on mobile


    hafeezsaeed
    Participant
    This reply has been marked as private.

    hafeezsaeed
    Participant
    This reply has been marked as private.

    Hi @hafeezsaeed

    The preloader is showing up, so it means the site is actually working but there is a missing/broken file that is why the preloader wont stop.

    The best thing you can do is disable the preloader animation from Theme Options so that you will see the site load and you’ll be able to identify which image/file is missing/broken.

    I tried to login to your site to do this but the credentials do not work.

    Thanks!


    hafeezsaeed
    Participant
    This reply has been marked as private.

    Hi @hafeezsaeed

    The page should now be working again. I just copied all the current codes in the page, removed the Rev Slider, then added it back.

    Can you please check if everything looks good now?

    Thanks!


    hafeezsaeed
    Participant
    This reply has been marked as private.

    Hi @hafeezsaeed

    I have tested your site and the size of your homepage is quite big at 8MB (7MB of which are images):
    https://tools.pingdom.com/#!/dfJKfG/http://hafeezsaeed.com/

    To speed up the site, you will need to optimize the images you are using on your site. Adding a caching plugin and CDN should also help.

    Regarding the issue with the gallery, can you please provide us with more information? Screenshots should also help as I checked the page and I do not see any issues. Are you referring to the dimensions of the image on the lightbox?

    Regards,


    hafeezsaeed
    Participant

    Hi

    Please can you tell help me get the cache and cdn? I don’t know what they mean? Also by optimise do you mean I should educe the image file size for the slider revolution or all of the pictures through out the home page?

    Many thanks
    Hafeez

    Hi @hafeezsaeed

    You can use WP Fastest Cache plugin to help speed up your site.

    Yes, you have to optimize all the pictures on your homepage.

    Regards,

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.