Home / Forums / DynamiX Support / Slow website since theme upgrade…

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts

  • Alistair Cowan
    Participant

    Love the upgrade of the theme – however, it has now caused my website to slow down dramatically. Can anyone see what is causing it?? It is found at:
    http://www.rollercoasterband.co.uk/
    Thanks,
    Alistair.

    Andy
    Andy
    Keymaster

    Hi Alistair,

    You’re currently using 3.0.3 – the latest version has just released today – 3.0.4. Try upgrading to 3.0.4 as it now uses the latest Twitter API, they stopped using the method that’s in 3.0.3 and maybe causing the delay.


    Alistair Cowan
    Participant

    Thanks for getting back – have just upgraded – still very slow. It’s either the server I use, or a plugin… I guess. Any thoughts appreciated, as I’m trying out things like the Yslow yahoo extension for Safarri to analyse the site, and I can’t make any sense from it (not being any kind of expert).

    Andy
    Andy
    Keymaster

    No problem, I’ve just done a test with Pingdom and you currently have a 11 second wait time from your server.

    http://tools.pingdom.com/fpt/#!/b50ud9/http://www.rollercoasterband.co.uk

    One thing that maybe worth trying is removing the following line from the DynamiX/functions.php page.

    require NV_FILES .'/adm/inc/note-admin.php';

    And if you have Flickr enabled, try disabling that to see if it has an affect .


    Alistair Cowan
    Participant

    I removed the code, and no effect – hopefully it wasn’t important… I guess you’re the one who’d know 😉

    I then removed my flickr id from the DynamiX Theme Options section… and the website suddenly sped up. Shame, as I reckon that would have been a really nice feature – it’s a pain using plugins to link through to the flickr site. I take it that it works ok with other people’s flickr account id’s?

    Thanks again for the help.

    I 2nd this opinion, my site has also slowed WAY down.

    Andy
    Andy
    Keymaster

    Yep, I can confirm that loads a lot faster! No worries, I’ll get on the case of seeing why the API is taking so long to load the data in. 🙂

    The part you removed was for admin update notification of theme updates. You can place this back in now.

    Craig, what’s your URL and are you using Flickr – I can guarantee it’s not the Theme itself ( unless you have flickr enabled it seems ), it scores extremely well for page load speed.


    Alistair Cowan
    Participant

    Thanks Andy – I’ll try and figure out where that code is meant to go back in.. probably just replace the file with the original. Thanks, Alistair.

    Andy
    Andy
    Keymaster

    @hep2djive – I’ve tested your site and the page load is still scoring very high – http://tools.pingdom.com/fpt/#!/cGjqRS/http://www.lewisvillenoonrotary.org

    The way to improve further is down to your server settings.

    Andy
    Andy
    Keymaster

    Hi Alistair,

    I believe I’ve fixed this now – it’s a 100% quicker. If you have FTP access, I can post up the file that fixes it?


    Alistair Cowan
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi,

    Here is the link to the file:

    http://help.themeva.com/tmp/core.php.zip

    Unzip and replace:

    DynamiX/lib/adm/functions/core.php ( make a backup of it first ).

    Let me know how it goes.


    Alistair Cowan
    Participant

    Initially it looks like it’s working, though I haven’t added any flickr sets via the DynamX interface. I reckon it’s fixed… excellent work – thank you. Looking forward to when you will be able to add single flickr photos as well as sets – then my quest for easy blog updating will be complete 😉

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.