Home / Forums / DynamiX Support / space between tabs and content box

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts

  • drijen
    Participant

    Hi there,

    I have created this site: http://drijendesigns.co.uk/ using this excellent theme.

    On the homepage, in the bottom right, you will see a 3 tabbed box.  For the 1st tab, it is fine, but for the 2nd and 3rd tabs, the content box has a gap above it, so the tabs are seperate from it.

    Anybody know why?

    here is the code used:

    [tabswrap] [tabhead id="1"] Clients [/tabhead] [tabhead id="2"] How We Work [/tabhead] [tabhead_last id="3"] Quick Quote [/tabhead_last] [tab id="1"]

     

    <h3>Who we work with</h3>

    We work with forward thinking small to medium businesses, looking to utilise the online world to enhance productivity and growth. Our clients are local (based on London), national and international. [/tab] [tab id="2"]

    <h3><span style="font-size: 15px;">Keeping things simple</span></h3>

    Working with us is easy – both organised well so you know exactly what is happening at each stage, and flexible, so that we can flow with unexpected changes in specification. [button url="about"  color="aqua"  ]Read More[/button]   [/tab] [tab id="3"]

    <h3><span style="font-size: 15px;">Free quote</span></h3>

    If you like what you see, and would like us to give you a free quotation for your project, please get in touch.

     

    Please note, due to a high level of demand, apart from exceptional circumstances, we currently no longer cater for projects that are worth under £1500.

     

    [button url="contact-us"  color="aqua"  ]Free Quote[/button] [/tab] [/tabswrap] [/two_columns_last] [hozbreaktop]
    Andy
    Andy
    Keymaster

    Hi,

    If you're going to insert code, highlight the code and selected Format -> Formatted, it will stop it being processed. 

    It looks like you have butted the shortcodes together and that's why there is a space. Make sure each tab content is butted up against the last one. Should do the trick. 

    e.g. 

    [tab id="1"]  tabcontent 1  [/tab] [tab id="2"]  tabcontent 2  [/tab]

    NOT


    [tab id="1"] tabcontent 1 [/tab]
    [tab id="2"] tabcontent 2 [/tab]

    drijen
    Participant
    Hi there,

    I am not sure how to select Format > Formatted, so I am embedding the image of the code…

    I have removed as much space as possible, but still doesn't seem to work…

    Andy
    Andy
    Keymaster

    That's really strange – I'm looking at the code and it has two " " quote marks between the first and second tabs. But I can't see that in the code above. Do you have any plugins installed?


    drijen
    Participant

    Hi there,

    apologies for late reply – been away for some time. The only plugins I've got installed are:

    BPS Security

    Gregs High Performance SEO

    Contact Form 7 with RECAPTCHA

    Google XML Sitemaps

    Cheers!


    David
    Participant

    I have a similar issue, actually it is a consistent effect throughout the theme, that the third column or tab drops down a bit, does anybody know how to correct this?

    Thanks


    David
    Participant

    I have a similar issue, actually it is a consistent effect throughout the theme, that the third column or tab drops down a bit, does anybody know how to correct this?

    Thanks

    Andy
    Andy
    Keymaster

    Hi David,

    It's wordpress putting in extra HTML elements. Best thing to do is make sure the shortcodes are aligned next to each other with just 1 space between. e.g. [column 1] [column 2] [column 3]


    drijen
    Participant

    Hi Andy,

    Have you got any idea why its doing it to mine? Here is the code…still not sure what i am doing wrong? pls help 🙂


    [two_columns_last ] [tabswrap] [tabhead id="1"] Clients [/tabhead] [tabhead id="2"] How We Work [/tabhead] [tabhead_last id="3"] Quick Quote [/tabhead_last] [tab id="1"] <h3>Who we work with</h3> We work with forward thinking small to medium businesses, looking to utilise the online world to enhance productivity and growth. Our clients are local (based on London), national and international. [/tab] [tab id="2"] <h3>Keeping things simple</h3> Working with us is easy - both organised well so you know exactly what is happening at each stage, and flexible, so that we can flow with unexpected changes in specification. [button url="about" color="aqua" ]Read More[/button] [/tab] [tab id="3"] <h3>Free quote</h3> If you like what you see, and would like us to give you a free quotation for your project, please get in touch. [button url="contact-us" color="aqua" ]Free Quote[/button] [/tab] [/tabswrap] [/two_columns_last] [hozbreaktop]

    drijen
    Participant

    sorry about above – i used your tip and hightlighted the code and clicked "formatted" but it looks like it processsed the code!

    here is a the code as an image….

    Andy
    Andy
    Keymaster

    You could try removing the space between the shorcode code and the h3 tags. See if that fixes it. 

    The alternative is using a plugin like ps disable autoformatting which stops wordpress inserting extra code. 

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.