Home / Forums / DynamiX Support / Sticky menu question

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts

  • Jim Donaghue
    Participant

    Hi guys, quick question on the sticky menu – is there any way to turn it off for mobile users?

    I dont use responsive ( i think mobile users can find their way easily enough and don’t need to be railroaded), but i think a sticky menu can be a real pain in the ass taking up alot of mobile page space.


    Trevor McCool
    Participant

    I am wondering the same thing. I’m working on a site now where I love the use of sticky menu, but not for mobile devices. It’s actually visibly blocking my slider on the top of my homepage. See http://360u.biz/beta for example

    Andy
    Andy
    Keymaster

    Hi Guys,

    To disable on Mobile, try the following code in Appearance > Theme Options > Customize > Mobile CSS

    .header-wrap.stuck {position:relative !important;}

    .header-wrap.stuck .custom-layer,
    .header-wrap.stuck #header,
    .header-wrap.stuck #header-logo #logo {height:auto !important;margin:0 !important;}

    .header-wrap, #header-logo #logo, .header-wrap .custom-layer {
    transition:none !important;
    -moz-transition: none !important;
    -webkit-transition: none !important;
    }


    Trevor McCool
    Participant

    Works great, thanks Andy!


    Thanatermesis
    Participant

    Thanks for the answer, Im going to try it too on my site (I did a small search in the forum before to post my question)

    IMHO the sticky menu should be by default disabled for the mobile mode, its totally useless to have this kind of “huge bloated banner” flying around our small screens :), try to enter in a dynamix site from an iphone and you will see

    Thanks
    Thanatermesis


    Thanatermesis
    Participant

    Aaah, much better! Now looking it from my mobile looks like to be a real useful website :), now is readable


    Johua Wilson
    Participant

    I was wanting to accomplish the same task. I copy and pasted in the code, but it didn’t work. Is the code perhaps out of date? If at all possible I would really like to be able to disable it on mobile devices.


    Johua Wilson
    Participant

    Note:Above
    Failed to mention that I am trying to do this on the Terso theme. I could not a find a post relating to this topic in that forum.


    Tom ( Support)
    Keymaster

    Hi Johua,

    This can be achieved but as it is not a standard theme option it is classed as a customization. You can view the comprehensive Custom CSS screencast here, this will give you more information on how to customize elements. On the other hand, you can request customizations through the customization forum here.

    Kind regards,
    Tom


    Johua Wilson
    Participant

    Sounds great, thanks for the heads up!


    MediaLoaf
    Participant

    The code you gave above works great in terms of stopping the nav from moving, but it still changes into the sticky nav layout when you start to scroll away from it. Is there any way to turn the sticky COMPLETELY off on mobile?


    Tom ( Support)
    Keymaster

    Hi Josh,

    If you have entered the code correctly into Appearance > Theme Options > Customize > Mobile CSS it should work fine.

    Are you using the latest version of DynamiX?

    Kind regards,
    Tom


    MediaLoaf
    Participant

    Tom,
    Thanks for your help. I have entered the code there and as I stated it works great at keeping the nav on the top of the screen. What it doesn’t do, however, is stop it from changing to the semi-transparent/smaller logo sticky bar that covers the search field when you start to scroll down the page.


    Tom ( Support)
    Keymaster

    Hi Josh,

    It should completely remove it from mobile. It will still be there for the desktop site as you are pasting it into the mobile CSS field.

    If you are still having issues, please set your reply to private and provide your URL/login details so I can take a further look for you.

    Kind regards,
    Tom

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.