Home / Forums / DynamiX Support / Tab switch causes vertical scrolling

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts

  • Peter
    Participant

    Hello,

    when I use a tab element and switch between the tabs the switch causes the effect that the page scrolls upwards. Is there a possibility to avoid this and fix the page in position?

    For example:

    http://www.finanzfinder24.de/geld-und-anlage/finanzvergleiche/tagesgeldkonto-vergleich/

    Andy
    Andy
    Keymaster

    Hi Peter,

    The only way to achieve that is to space out the content so that they’re equal. You can do that easily by going to the shortest tab > add element at the bottom of the content > select “empty spacer” and experiment with the size to balance the sizes.


    Peter
    Participant

    Hi Andy,

    this does not help. Even when I put an empty tab element to the page and switch between the empty tabs (they must be equal) the page walks upwards with every click on a tab.

    To be seen here:

    http://www.finanzfinder24.de/test

    Login with: 123456

    Andy
    Andy
    Keymaster

    Hi,

    Did you change something as it doesn’t appear to be doing it any longer?


    Peter
    Participant

    Hi,

    I have not changed anything. The effect is still there. You have to scroll to the end of the page and then click the tabs to see the movement.

    Andy
    Andy
    Keymaster

    Hi Peter,

    It’s browser window and page position which determines the effect of the issue. I’ve resolved it, you’ll need to replace DynamiX/js/nv-script.pack.js with the following file ( unzip ):

    http://help.themeva.com/tmp/dynamix/nv-script.pack.js.zip

    You’ll need to clear your browser cache and then you should be okay. Let me know if it’s okay for you.

    Kind regards,

    Andy


    Gareth Jones
    Participant

    I’m getting this too – I’ve included my FAQ elements in a tabbed area, and when you switch tabs the page scrolls up.

    Have you integrated this fix into the Theme, or is it special. If so, can you re-upoad the fix for me please?

    Andy
    Andy
    Keymaster

    Hi Gareth,

    It’s long been fixed since then. Have you updated the theme to the latest version?


    Gareth Jones
    Participant

    Yes – afraid so. I may try upgrading again or just replacing all the files using ftp. I know I had some problems with the upgrade – but I thought it had completed successfully.


    Abdullah Jangda
    Participant

    This is happening to me as well when I put quotes in the pageable container and set it to autoplay.

    I updated to the latest version 4.11.2

    Please let me know how to resolve it.


    Abdullah Jangda
    Participant

    I meant version 5.3 of Dynamix and 4.11.2 of visual composer but still having this issue. Please help

    Hi @abdullahjangda

    Can you please send over your site’s URL and login credentials so we can personally test and check on this further from our end?

    Regards,


    Abdullah Jangda
    Participant
    This reply has been marked as private.

    Hi @abdullahjangda

    Can you please specify which page the issue is happening on so we can check this further as you currently have a number of active pages?

    Regards,


    Abdullah Jangda
    Participant

    Sorry, here is the page we have the pageable container on and are having trouble with.

    http://www.qalaminstitute.org/seerahintensive/

    Please let me know what the fix is so we can replicate or remove it later if needed.

Viewing 15 posts - 1 through 15 (of 25 total)

You must be logged in to reply to this topic.