Home / Forums / You Theme Support / Text "jumping" spaces on mobile devices

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • Hi Support

    We have a problem on several of our pages as the text is “jumping” a lot of spaces. It seems to occur only when viewed on mobile devices. It should be formatted correctly in Wordpres and I have tried to replace the whole text, but the problem re-occurs. Example under the “Mere information” section in a mobile browser here: blivvaccineret.dk/vaccinationer/vanuatu (there is way to much space between “forventede” and “rejse”).

    Any suggestions?

    Thanks in advance,

    Mathias

    Hi @mathiasklokpedersen

    Can you send over your site’s URL and login credentials so we can check on this further from our end?

    Regards,

    This reply has been marked as private.

    I checked the page you mentioned and with “jumping”, I think you are referring the sudden breaks on the sentences leaving space big spaces between the words?

    Looking at it, there seems to be spaces added using   tag that breaks spacing between the words. The best option is to copy the text to notepad, then copy and paste it back to the HTML editor. This will make sure those special spaces are removed. I did it for the paragraph with “forventede” and “rejse” and you should see that the breaks don’t happen anymore.

    Can you please check and confirm from your end? If you want the text blocks to look better aligned, we can add CSS to break the word or just justify the paragraphs.

    thanks!

    Thanks. I cannot reproduce your solution, though. Also, I don’t see the &nbsp tag anywhere in frontend, backend or classic editor mode (I have checked both visual and text)?

    For instance in mobile browser on the same page blivvaccineret.dk/vaccinationer/vanuatu I see too much space after the “og” in “Vaccination mod kolera og rejsediaré” (in “Rejsediaré”section). And the same after the “til” in “Ved rejse til risikområder anbefaler…” (in “Anbefalinger” section).

    I have tried to copy the whole paragraph to both Textedit and Stickies on Mac, deleting and saving in WordPress, and copy it back in. No effect in mobile browsers.

    How does this occur in the first place? (we have +200 pages with 6 paragraphs each, so it will be a lot of manual editing to correct – are we doing something wrong in the first place?). It is not strongly compromising the site, but still – it could be nice to avoid.

    If I justify the paragraphs now, it will look even more awkward, as there is still too many spaces between some words.

    Thanks again,

    Mathias

    Hi Mathias,

    We sincerely apologize for the delayed reply.

    The stray   can be seen on Chrome Dev Tools particularly. Here is the screenshot. http://i66.tinypic.com/2qw0cjn.png

    If you checked, the ‘jump’ happened on ‘der’ because it looks like with the stray &nbsp the browser is considering ‘der’ and ‘overfores’ as one word.

    We can’t particularly tell what is causing this. If you typed your text elsewhere then just copied and pasted it to Visual Composer, that is possibly encoding on the editor you used originally.

    It is also possible that this is caused by a plugin, so you can try to disable all of them and leave Visual Composer to test.

    Thanks!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.