Home / Forums / DynamiX Support / Theme Page Load Time

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts

  • Bram van der Veen
    Participant

    Hello!

    The page load time of my site is 16.95s (using tools.pingdom.com) when I have the Dynamix Theme activated.

    This goes down to 3.37s when I activate Twenty Fifteen.

    How can I bring down the page load time with the Dynamix theme?

    Thank you


    Bram van der Veen
    Participant
    This reply has been marked as private.

    MFKing
    Participant

    Any updates on how to speed it up? I’ve noticed the same thing…


    Bram van der Veen
    Participant

    Not yet, waiting for a response.

    Andy
    Andy
    Keymaster

    Hi Bram,

    It’s not the theme itself, there must be a combination of things that’s causing this. If you check the http://dynamix.themeva.com site for example, you’ll see that scores well.

    I would recommend using WP fastest cache instead of the caching plugin you’re using.

    However, there is something which is seriously slowing down your site – I’d check by disabling all plugins and re-activating one-by-one to see which one is having the biggest affect. I’d be interested to know what you get with just the Theme and the basic plugins ( Visual Composer ) in comparison. You’ll need to flush your cache each time.


    Bram van der Veen
    Participant

    Hi Andy,

    Thanks for your reply. I’ve done some more testing, by disabling all plugins. At the moment I only have Revolution Slider and VC active. At the moment the admin bar and VC elements don’t show. As soon as I deactivate Revolution Slider, the admin bar pops up again as well as VC elements.

    This seemed to have happened after updating VC to 4.3.5.

    Can you help?


    Bram van der Veen
    Participant

    When I only have VC activated, and not other plugins, the site works but load time is 13seconds! I’m sure there’s an issue with VC.

    Andy
    Andy
    Keymaster

    I’m wondering if your server is prevent access to certain files being loaded. That would usually cause that sort of page load time. It maybe worth asking your hosting if they can see anything that is blocked or restricted access.

    Even with VC disabled, 13 seconds is very long load time.

    I switched to the core theme and that appeared to speed things up, but still not exactly what you’d expect. Is there any other modification to the theme and do you have much in your .htaccess file on your server?


    Bram van der Veen
    Participant

    Hi Andy

    There’s nothing in my .htaccess (except for the standard text). I’ve checked with my Hosting company and they say everything is fine.

    This all seemed to have happened after updating VC, before everything was good!

    🙁


    Bram van der Veen
    Participant

    And when I activate another Theme, everything works fine and page load is really fast, so it does seem it’s an issue with Dynamix.


    Bram van der Veen
    Participant

    Finally, the issue only occurs on the homepage, all other pages load fine!


    Bram van der Veen
    Participant

    The VC backend editor also doesn’t show up either when trying to edit the page (and yes I did activate it on the settings page)

    Andy
    Andy
    Keymaster

    Hi Bram,

    Are the other themes loading the same content on the homepage? I.e. Slider Revolution etc? It has to be something on your homepage if the other pages are loading okay.

    I’ve done some more digging about and something really isn’t right with the theme. It’s not showing the page options correctly. I would try re-installing the theme again ( both core and child theme ) and see if that resolves it.

    If you post your FTP, I’m happy to do it for you.

    Kind regards,
    Andy


    Bram van der Veen
    Participant
    This reply has been marked as private.

    Bram van der Veen
    Participant
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.