Home / Forums / You Theme Support / Theme Post Options Only Show on Default Wp Post and Not on Custom Post types

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • awesome
    Participant

    Hello,

    I have noticed that I cannot get the theme individual post settings tab to show on custom post types as shown in the images below. I think this is a bug and I wanted to put it forward so that I can be fixed in the next theme update.
    Normal post:
    https://imgur.com/a/ZRMrD

    Custom post:
    https://imgur.com/a/AsiH7

    Hi @norsam

    Technically, it should work since basing on my test site, the options appear when creating a Portfolio item, which is considered a Custom Post type.

    Have you tried to disable all your plugins to check if any of them is causing the issue?

    Regards,


    awesome
    Participant

    Hi Edcel,

    I have effectively determined that it is not a plugin conflict. This is what’s going on:
    The portfolio post types shows the theme options for its posts. But custom post types created with any other plugin do not show theme options. I am using a plugin called Custom Post Type UI. But none of the custom post types that I create have the theme options showing up for them.

    But the portfolio post type plugin that comes with the You theme will show the theme options.

    I want to use my own post type called “Books”.

    Hi @norsam

    I have tested this on my site using Custom Post Type UI plugin, and indeed the options for the theme do not appear on the post type.

    I will forward this to the developer to check if it’s an easy fix or for consideration on future updates for the theme.

    Regards,


    awesome
    Participant

    Thanks Edcel.
    I just hope he can keep up with all the suggestions.

    Hi @norsam

    It is a valid suggestion which really makes sense, so I hope it will get implemented as well because there is a possibility another customer may ask for it. 🙂

    Regards,

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.