Home / Forums / DynamiX Support / Tooltips shortcode bugs

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts

  • Thanatermesis
    Participant

    Hi,

    The tooltip shortcode adds newlines where are not needed, it breaks the design of the contents when used in the middle of a sentence and it adds extra spacing when used in the end of a sentence (only possible to use on this way in order to not break the contents)

    Example: Our system is [tooltip icon=”yes” color=”light” tip=”you can run any number of applications at the same time, only limited by your amount of RAM memory”]multitasking[/tooltip] where you can do foo and bar.

    Also, the option icon=”no” or removing it doesn’t seems to hide the icon (i suggest to have the word underlined so that the user can know that he has something by moving the mouse to this word)

    By the way, I’m considering this more powerful tooltip system, maybe you are interested on integrate it on dynamix 🙂 http://codecanyon.net/item/wordpress-litetooltipjs-plugin/full_screen_preview/4165378

    Thanks
    Thanatermesis


    Tom ( Support)
    Keymaster

    Hi,

    It seems like WordPress doing it by adding in extra characters. It is really frustrating but with ThemeForest’s new regulations you aren’t aloud to touch the WordPress editor so we cannot do anything about it as they are being very strict recently. I recommend putting the tooltip at the end of the sentence or before to get the look you are going for.

    Kind regards,
    Tom


    Thanatermesis
    Participant

    Each day I’m more unhappy with the themeforest service

    I don’t see any extra character in my editor (text/html mode, i mean, where you should see everything, right?), well the source code looks like this and doesn’t seems to be very clean/correct:

    <p>Elive is robust, stable, and <span class="tooltip-info icon " data-tooltip-position="">multitasking <span class="tooltip-icon"> </span></span><span class="tooltip light">you can run any number of applications at the same time, only limited by your amount of RAM memory </span></p>


    Tom ( Support)
    Keymaster

    Hi,

    There will be no extra characters in the editor, but on the front end you will see a big drop after the tool tip. If you inspect element, you will see the tool tip cuts off the p tag and creates a new one for the new line down. Very frustrating indeed.

    Kind regards,
    Tom


    Thanatermesis
    Participant

    Yeah sure, these things are always frustrating, I wonder “why” the WP editor simply adds them.

    Thinking about the problem of themeforest, I think that a solution for you can be to have special options in the configuration of dynamix, like checkboxes disabled by default with optional configurations like “modify the editor when needed” etc… something like a specific tab explaining themeforest rules and stuff, if they are disabled by default and explained, there should be not any policy problem with the themeforest guys, because is totally optional to the user to use or not those “risky options” (in the point of view to these dictatorships). I can understand that dynamix should do (hack/modify) some things of WP in order to be correctly integrated in the behaviour wanted, sometimes these things are needed.

    Thanks
    Thanatermesis


    Tom ( Support)
    Keymaster

    Hi,

    I will suggest this to Andy but any work around for this TF won’t accept. It is very annoying but there is not much we can do at this point.

    Kind regards,
    Tom


    Thanatermesis
    Participant

    I wonder if this is related (fixed in 3.7 aparently) http://core.trac.wordpress.org/ticket/6562


    Tom ( Support)
    Keymaster

    Hi,

    This post is to do with special characters in the Visual editor unfortunately not related to our problem.

    Might be worth trying this plugin out here.

    Kind regards,
    Tom

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.