Home / Forums / DynamiX Support / Undefined variable

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • Erwin Caravana
    Participant

    Hi,

    I’m not sure why I have this notice message popping up.

    Notice: Undefined variable: imagefull_color in /home/gearkb/public_html/wp-content/themes/DynamiX/lib/inc/sub-functions.php on line 479


    Tom ( Support)
    Keymaster

    Hi,

    Are you using the latest version of Dynamix? It might be because you’re using PHP 5.4, you can turn off error_reporting for the time being to solve this issue. In PHP 5.4, the error reporting is switched on automatically and is set to strict, it simply shows errors that are really a problem. Very annoying but this should fix things.

    See here for disabling errors.
    http://www.websitedefender.com/forums/websitedefender-general/php-errors-enabled

    Kind regards,
    Tom


    Erwin Caravana
    Participant

    Hi Tom,

    Thanks for the reply. I am using the latest version DynamiX 3.1.2 and PHP version 5.2.14.

    I also missed these 2 other ones in the footer.
    Notice: Undefined variable: layerset3 in /home/gearkb/public_html/wp-content/themes/DynamiX/footer.php on line 87
    Notice: Undefined variable: layerset4 in /home/gearkb/public_html/wp-content/themes/DynamiX/footer.php on line 88

    For now I will disable the error reporting until there is a solution to fix these. Just wondering are these just some common types of errors?


    Tom ( Support)
    Keymaster

    Hi,

    These aren’t critical errors but I can take a quick look at your sites code to see if everything is running OK if you want to provide your URL?

    Kind regards,
    Tom


    Erwin Caravana
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi,

    There are no critical errors on your site, once the error reporting is turned off, the top errors should disappear.

    Hope this helps.

    Kind regards,
    Tom

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.