Home / Forums / DynamiX Support / Update 3.0.4: Illegal string offset error from js_composer

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts

  • Thomas Malbaux
    Participant

    Hi,

    I really enjoy your theme and use it to create a new website (not available yet).
    I updated earlier today the DynamiX theme to 3.0.4 and I receive the following warnings:

    Warning: Illegal string offset 'type' in /homez.534/choeurle/www/wp-content/themes/DynamiX/lib/adm/inc/js_composer/composer/lib/mapper.php on line 75
    Warning: Illegal string offset 'param_name' in /homez.534/choeurle/www/wp-content/themes/DynamiX/lib/adm/inc/js_composer/composer/lib/mapper.php on line 78
    Warning: Illegal string offset 'param_name' in /homez.534/choeurle/www/wp-content/themes/DynamiX/lib/adm/inc/js_composer/composer/lib/mapper.php on line 80

    These warnings appears at the top of the webpage and repeat 6 times. It happens in back-office as in front-office.
    They are related to the DynamiX\lib\adm\inc\js_composer\composer\lib\mapper.php file. This file has been changed since 3.0.3.

    Do you have any idea what the reason of the error is?
    Should I change anything in my settings to avoid it?

    I noticed, via search, that some issues occured with this file with your Tersus theme as well. Maybe there is a similar issue/solution?

    Let me know if you need more information,
    Thanks.

    Andy
    Andy
    Keymaster

    Hi Thomas,

    It’s something I’ll pass onto the developers of Visual Composer – their PHP 5.4 support is a little up and down at times.

    They’ve been great recently with some issues I’ve found, so this shouldn’t be too much of an issue for them.

    I don’t want to hack anymore of the files of the plugin more than I have already, your best bet would be to disable error_reporting for PHP 5.4, these are just warnings but unfortunately they get in the way.

    Have a look at this guide to disable the errors:

    http://stackoverflow.com/questions/9983286/disabling-strict-standards-in-php-5-4

    If you don’t have access to .htaccess or your php.ini I’ll look at changing the file so that it’s compliant.


    Thomas Malbaux
    Participant

    Hi Andy and thank you for your quick answer.

    I totally understand that you don’t want to manage too much of the plugins (this is not your main job here ;)). Thanks if you let them know about this error.

    Instead of disabling error_reporting (it worked but I like to see them if they happen), I set the PHP version back to 5.3.16 (the default 5.3 one offered by my host) and I no longer see the problem.
    As 5.2.4 at least is required for WordPress (and if your theme doesn’t require a greater PHP version), I guess this will be enough while the Visual Composer team improve their plugin.

    Thanks again for your help and keep up the good work 🙂

    Andy
    Andy
    Keymaster

    No problem Thomas,

    The main difference between PHP 5.3 and 5.4 is that they’ve set the error_reporting on by default and have set it to strict, so not even the slightest error gets past it. If you’re happy to do that, that’ll work too 😉

    I’ll get onto them tomorrow! 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.