Home / Forums / ePix Support / Update issue

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts

  • Pete Barnes
    Participant

    Hi Andy
    Apologies for this, I imagine you get this one quite a lot as I’ve been searching through similar threads for the last hour. After the complete debacle with my web hosts a few weeks ago I am a bit loathed to go to them so I thought you should be my first port of call. I am trying to update epix using the Envato update plugin. I have set it up fine and epix has popped up to update automatically but when I try I get this error:

    Download failed. SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    Is this an issue I need to talk to my hosts about? If you can help that would be infinitely more preferable! (I have wordfence installed as well if that is anything to do with it?)

    Kind regards

    Pete

    Andy
    Andy
    Keymaster

    Hi Pete,

    I think the first thing would be to disable wordfence and try again. In this new version there is an automatic update for future versions, should make things a little easier.

    Let me know how that goes with disabling the wordfence plugin.

    Kind regards,
    Andy


    Pete Barnes
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Pete,

    I’d disable all plugins apart from the Envato one and see what happens then. If not, it’s probably something you need to ask your hosting about as that article mentions placing something in the php.ini file to stop the message.


    Pete Barnes
    Participant

    Hi Andy,

    Tried that, still no luck, I’ll try the hosts and see what they say, thanks anyway (sites been flawless since your help!)

    Kind regards

    Pete


    Pete Barnes
    Participant

    Found this Andy, would it be a case of just downloading the .crt and putting it in the includes/certificates folder?

    Symptom:

    In WordPress, when trying to install a Theme, view the RSS or performing other operations that use CURL, the following error message appeared:

    SSL certificate problem, verify that the CA cert is OK.
    Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    Solution:

    This is because WordPress is using its own certificate bundle, overriding the global system certificate bundle. The problem is that the certificate bundle that WordPress has is old and needs to be updated. To do this, please download the latest one from http://curl.haxx.se/ca/cacert.pem and save it as ca-bundle.crt

    Upload this file to: wp-includes/certificates/ca-bundle.crt

    Kind regards

    Pete

    Andy
    Andy
    Keymaster

    Hi Pete,

    By that description it does looks like it is just a case of uploading it to that folder. I would make a backup of the current one and see try it out, I’ve never come across this issue before so it’s new territory for me too.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.