Home / Forums / You Theme Support / Update to 1.5.1 broke several things

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts

  • nilayshah
    Participant

    Updating the website to version 1.5.1 on WordPress 4.7 broke several pages and elements. Below is the list of things i could find so far that are broken.

    Mobile – Menu

    1. Sub menus have a black background and also don’t collapse in mobile view.

    Careers

    2. Current vacancies show up as a very thin column in the center in mobile view.

    Portfolio Detail page

    3. Image & text cut from top in desktop view. & Single Portfolio pages have started displaying wrong path. instead of http://www.websitename.com/portfolio/single-portfolio-1 it has started nesting under blog as http://www.websitename.com/blog/portfolio/single-portfolio-1 . However when you open the main portfolio page it’s URL is correct http://www.websitename.com/portfolio/ . This is something very strange.

    4. Image cut from top in mobile view.

    Blog

    5. Image & text cut from top in desktop view.

    6. Image not visible in mobile view.

    FAQ

    7. Text cut from top in mobile view.

    • This topic was modified 3 weeks, 3 days ago by  nilayshah. Reason: Added more information of portfolio URL issue

    nilayshah
    Participant
    This reply has been marked as private.

    Hi @nilayshah

    1. This is the submenu background color you set under Customize. If you want to keep gray background on submenus when on desktop and white on mobile, copy and paste this CSS into Theme Options > Custom CSS > Mobile CSS:

    .site-inwrap .skinset-submenu.acoda-skin {
        background-color: #ffffff;
    }
    .site-inwrap .skinset-submenu.acoda-skin li a {
        color: #333333;
    }

    2. This is getting cramped because you actually added 120px padding for the tabs. This means that on mobile, the padding will apply and the data will get cramped. You can either remove this padding or we can add a CSS to remove this padding on movile.

    Portfolio Detail page

    3. For your portfolio, the header is actually set as floating, that is why it overlays over the content. As an example, I disabled floating header for this page http://beta.appsnstuff.com/blog/portfolio/thumbtackbugle/

    You should see that the header do not overlap with the content anymore.

    For the slug, you actually added /blog/ as part of the permalink here: http://beta.appsnstuff.com/wp-admin/options-permalink.php

    A Portfolio Item is considered as a post type, that is why /blog/ gets added to it. The Portfolio page is not affected since it is a page, not a post type.

    4-7. The image/content getting cut/overlapped goes back to the floating header being enabled. If you do not want them to overlap, then please disable Floating header.

    For Visual Composer, you can download a more updated version here: http://acoda.com/tmp/js_composer.zip

    Regards,


    nilayshah
    Participant

    2) We will need to add a css to remove padding on mobile and tablets. Also the fonts for tab title needs to be white, don’t know how they became black. How to change color of that tab fonts?

    Portfolio Details Page:

    3) I had to add /blog/ in permalink because all the blog post were not showing as website.com/blog/blog-post-name without adding that slug. Any other way to show all blog-posts as http://www.website.com/blog/blog-post-name ?

    Also last time when we wanted to have the right column of single blog page to 25% instead of default 33%. You gave me this css to have the main area as 75% and right column as 25%

    @media only screen and (min-width: 1024px) { .single div#content { width: 75%; } .single-post .sidebar { width: 25%; } }

    However the problem is that this gets applied to portfolio single page as well even when I don’t want it to. Any solution to apply it to single blog posts only and not to single portfolio pages?

    Visual Composer: Do you have the latest 5.1.1 or 5.2 ?

    • This reply was modified 2 weeks, 5 days ago by  nilayshah.

    2) I have applied the CSS that you requested and it is now working.

    Portfolio Details Page:

    3) You can install this plugin https://wordpress.org/plugins/custom-permalinks/

    This will enable to you to manually add /blog/ to blog posts without touching the permalinks for the portfolio items.

    Regarding the CSS, I changed it to @media only screen and (min-width: 1024px) { .post-template-default div#content { width: 75%; } .single-post .sidebar { width: 25%; } } which should only apply to blog posts and not on portfolio items.

    For Visual Composer, I will coordinate with the developer to check if we have the most updated version of VC.

    Regards,


    nilayshah
    Participant
    This reply has been marked as private.

    Hi @nilayshah

    2) Copy and paste this CSS into Theme Options > Custom CSS to fix the issue

    span.vc_tta-title-text {
        color: #ffffff;
    }

    3) You will need to manually add /blog/ to the slug of the post. I have edited this post and you can check it out: http://beta.appsnstuff.com/wp-admin/post.php?post=5536&action=edit

    What is the link to your portfolio page? The easiest option is to setup a redirect from http://beta.appsnstuff.com/portfolio/ to your Portfolio page.

    8) Copy and paste this CSS into Theme Options > Custom CSS to fix the issue

    div#blog_container .splitter-wrap {
        margin-top: 20px;
    }

    Regards,


    nilayshah
    Participant

    3) I have been using http://beta.appsnstuff.com/portfolio/ as the portfolio page without any issues. This URL used to open our main portfolio page. But now you can change to URL of the portfolio page to anything, it will still display the portfolio archives page only. As you can see now i have changed the url to http://beta.appsnstuff.com/portfolios/ still its showing the archive page. I guess The issue may have started after installing the custom permalinks plugin or after the latest theme update.

    Hi @nilayshah

    Can you please disable the Custom Permalink plugin and check if the portfolio page will work and not show the archives?

    Regards,

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.