Home / Forums / DynamiX Support / Upgrading to 2.9, using Child Theme – blog excerpts formatting differently

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author

  • Chris Alford



    I am in the process of upgrading from 2.8.7 to 2.8.9, but using the child theme method (rather than just editing the style.css file everytime as I have been doing). I don’ think that is causing the problem I have but I mention it just in case.


    Anyway, the site is pretty much how I want it with the child theme, but the blog on the home page looks all over the place. Basically, what appears to be happening is that before each blog post would show up as <image> <h2>title</h2><p>first x characters of post REGARDLES of styling in the post</p>. But now each blog post shows up as <image><h2>title</h2><h2>subtitle</h2><p>opening sentence</p> and the extra formatting is throwin the page out of shape.


    I can’t find anywhere a setting to ‘remove’ the styling fromblog posts in the excerpts, and I have searched through the blog.php file to see if there is anything there that needs to be edited? It is possible that the site php pages on the 2.8.7 version of my site were modified (not by me) but I have no idea where to start looking. I am assuming that the Dynamxi settings themselves don’t change when I change themes but I have looked jsut in case and all seems as it should be.


    Any ideas much appreciated,



    Chris Alford

    Quick update. I found the Settings > Excerpt options. They don’t show up when I have 2.8.7 activated though, so guessing that’s a WordPress feature that is newly supported by 2.8.9? Anyway, unticking the ‘Generate code even if a custom excerpt exist’ box solved most of my problems. The main remaining issue is the post title still shows up as <h4> not <h1> like it used to, am looking all over to find where that is set. I appreciate it probably isn’t a Dynamix ‘problem’ but if anyone has any ideas I would be very grateful.


    Hi Chris,


    Can you post a link please – you can also disable certain HTML tags from getting though into the excerpt via the Settings -> Excerpt. Maybe worth seeing if you can tweak it by disabling the heading tags.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.