Home / Forums / DynamiX Support / Uploading Cufon – security warning

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts

  • IconicD
    Participant

    Update fixed – didn't realise we needed to upload the actual .js file rather than the unzipped .ttf  (Leaving post up in case others have the same issue and I'd say there is still a need for more detailed instructions)

    I'm trying to install a new cufon font so downloaded and extracted a font (example.ttf) from http://www.cufonfonts.com. However when I attempt to upload the file I get this WordPress warning:

    “example.ttf” has failed to upload due to an error

    File type does not meet security guidelines. Try another.

    I've tried many fonts and still the same message appears so can you please advise.  Also tried directly uploading the font to my server and pointing to the URL directly which doesn't seem to work either.

    Perhaps a simple step by step guide for installing cufon might be useful incase I'm not be the only one who found it unclear.


    Shaufi
    Participant

    Hi IconicD,

    Yes, i am one of those who have failed to get this so much so that  had to revert to another plugin to get this done. So have you succeeded? if you did, for the benefit of others (and mine =p ) woud you mind listing the steps?

    Thanks!


    Gareth Jones
    Participant

    Ah, coincidence I tried this yesterday and had the same issues. It's working now – so here are the steps I took.

    1. Download a Cufon font – lots of references on the web how to do this – but essentially either download a generated font, which will be a .js file. Or convert and existing font using the tools on the web. If you do use http://cufon.shoqolate.com/generate/ to generate a font then be sure to rename the generated .js file to match the font name before you upload it to your web site.
    2. Upload the .js file to your web site. Unless you've changed the media uploader to handle .js file – which I think is a dangerous thing to do – then you should us an ftp client and upload the file. I've put my int into the files section of the website where the other media is stored eg /files/2011/02/myfontfile.js
    3. Now copy this url into the Dynamix General settings Cufon Font dialog, and then hit save. screenshot
    4. Enjoy the new Font in your heading styles

    Hope this helps.

    I think the confusing thing is that the button on the settings form says upload – and this opens the media manager – which doesn't work for .js files – therefore frustration ensues!

    One thing I'd like to know is can the .js font file be uploaded anywhere in the theme eg the lib/js folder – that would seem tidier than putting it amongst the rest of the content, and also allow it to be used in a multi-site situation. I'll test this when I get more time…..


    IconicD
    Participant

    Hi Shaufi,

    Here's how I installed a new cufon font from the Dynamix general setting options step by step:

    1. Click on 'Download Cufón Fonts.' to search for a font you like.

    2. When you've found your font click on the last tab on the right above 'Cufon Dosyas?n? ?ndir'

    3. Now select any languages/charaters you want included by ticking/unticking

    4. Scroll down and tick the legal responsibility box then the submit button – Fontu Cufon Olarak ?ndir – to download the .js file

    5. Back in Dynamix, click on the Upload button and select the downloaded .js file from your computer.

    6. Copy the LINK URL – do not 'insert into post' – and close this pop up window.

    7. Paste LINK URL into the 

    That's how it works for me after many frustrating attempts to upload the actual .ttf fonts. Guess it didn't help that my Turkish is pretty poor 😉


    Shaufi
    Participant

    Thanks IconicD!!

    Works like a charm.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.