Home / Forums / ePix Support / VC 4.2.1 ( Warning: Illegal string offset ‘type’ ) fix

Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • Andy
    Andy
    Keymaster

    Hi Guys,

    For those of you received the error in the title, please apply this fix to the vc plugin:

    /wp-content/plugins/js_composer/include/classes/core/class-wpb-map.php

    With this file:

    http://help.themeva.com/tmp/class-wpb-map.php.zip


    Telepuzik
    Participant

    Hi Andy!!! You save my life!!! Was thinking to delete this theme, because do not have a CPanel and support do not want make php changes… Thank you for your fix!!!
    Love Themeva!!!

    Hi Andy, I followed your instructions above and I no longer can get into the dashboard. I cannot see anything. Below is what I received when I typed the domain in.

    Warning: require_once(/home3/tthazin/public_html/wp-content/plugins/js_composer/include/classes/core/class-wpb-map.php): failed to open stream: No such file or directory in /home3/tthazin/public_html/wp-content/plugins/js_composer/js_composer.php on line 138

    Fatal error: require_once(): Failed opening required ‘/home3/tthazin/public_html/wp-content/plugins/js_composer/include/classes/core/class-wpb-map.php’ (include_path=’.:/opt/php54/lib/php’) in /home3/tthazin/public_html/wp-content/plugins/js_composer/js_composer.php on line 138

    Resolved…


    Erin McGuire
    Participant

    Thank you for getting back to me so fast with a fix and I’m sorry to bother you again, but I dont know what to do with this file. I am not a web developer and follow the directions for the theme to get my website going. I can figure most stuff out on my own if you can just point me in the right direction.

    Thank you again


    Telepuzik
    Participant

    Hi Andy,

    when created new page and try to add new Grid Gallery getting error:

    Edit Grid Gallery

    Warning: Illegal string offset 'param_name' in /homepages/28/d530592945/htdocs/wp-content/plugins/js_composer/include/classes/shortcodes/shortcodes.php on line 846

    Warning: Illegal string offset 'param_name' in /homepages/28/d530592945/htdocs/wp-content/plugins/js_composer/include/classes/shortcodes/shortcodes.php on line 850

    Warning: Illegal string offset 'param_name' in /homepages/28/d530592945/htdocs/wp-content/plugins/js_composer/include/classes/shortcodes/shortcodes.php on line 862

    Warning: Illegal string offset 'type' in /homepages/28/d530592945/htdocs/wp-content/plugins/js_composer/include/classes/shortcodes/shortcodes.php on line 591

    Is any Idea how to fix it?
    Thanks again.
    Telepuzik


    Erin McGuire
    Participant

    Hey guys, its been a few days since I bought the theme and I still havent been able to start building because I am not sure how to apply this fix. Can somebody tell me if I need to install it like the other plugins or do I have to do something with the file directly in WP? Just need a little guidance. If I cant get it working, I need to get my money back and get a different theme as soon possible. I need to get my new site running as soon as possible for some upcoming shows.

    Thanks so much


    Telepuzik
    Participant

    Hey Erin,

    just download file above and replace your current one located on /wp-content/plugins/js_composer/include/classes/core folder.
    It works for me when I install theme first time…


    Erin McGuire
    Participant

    Thank you so much Telepuzik!!!

    Andy
    Andy
    Keymaster

    @telepuzik are you still having those issues? Is that on the latest version of the theme and VC 4.2.1? I see they’ve released yet another update… I’ll update the themes when I get back from my trip.


    Erin McGuire
    Participant

    Thank you Telepuzik and Andy! Im all set.

    And in case anybody else runs into this issue and is a novice at setting these WP themes up, that path is the path you follow in the file manager for your Host. In my case, I logged into my Godaddy account, went to my cpanel setup, file manager, and found the path from there. There is an upload option right there and you can overwrite with the new file. Worked like a charm.

    Thanks again all!!!


    Telepuzik
    Participant

    @Andy – Yes, still have issue only when create new page and only when you -> “+ add element”then “add Grid Gallery”, all another elements works fine.

    Andy
    Andy
    Keymaster

    That’s very strange, I’m going to pull it all apart over the weekend and get to the bottom what’s triggering VC to throw these errors up.


    LizardPC
    Participant

    I am also getting having the same issue as @telepuzik using the latest theme version, the patch above, and VC 4.2.1 except when I try to add a new Carousel slider

    Warning: Illegal string offset ‘param_name’ in /homepages/28/d530592945/htdocs/wp-content/plugins/js_composer/include/classes/shortcodes/shortcodes.php on line 846

    Warning: Illegal string offset ‘param_name’ in /homepages/28/d530592945/htdocs/wp-content/plugins/js_composer/include/classes/shortcodes/shortcodes.php on line 850

    Warning: Illegal string offset ‘param_name’ in /homepages/28/d530592945/htdocs/wp-content/plugins/js_composer/include/classes/shortcodes/shortcodes.php on line 862

    Warning: Illegal string offset ‘type’ in /homepages/28/d530592945/htdocs/wp-content/plugins/js_composer/include/classes/shortcodes/shortcodes.php on line 591

    Hi, I have written two different threads asking for assistance with my the plugin VC not being activated on my site. When I activate it, I get the same above error as LizardPC….can someone help me? No one has responded to my inquiries in two days….

    http://www.piixdot.com

Viewing 15 posts - 1 through 15 (of 27 total)

You must be logged in to reply to this topic.