Home / Forums / DynamiX Support / VC Grid Gallery – showing all products instead of 1 category

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts

  • Illuster
    Participant

    Hey Andy,

    After the updating theme Dynamix all my Grid Galleries show all of my (WooCommerce)products instead of just one category. For example: http://www.stipbike.nl/hey-cycles/
    The category slugname is “hey-cycles”. The category-name is “Hey Cycles”

    But if the category name is just one word everything is fine, see: http://www.stipbike.nl/vanmoof-2/
    So if the category name is one word, it works fine.

    Before this update everything worked fine.

    I contacted WPBakery Support and this is there respond:
    It is because there is an inbuilt version of Visual Composer (or the related code) present in your theme which is overriding the standalone plugin version and hence causing the issue. You will have to get rid of it. I would advise you to do so with the help of theme author, otherwise you might loose the extra elements added by him. Once this is done, you can install the standalone plugin and it will work fine. Kindly check.

    Could you help me?

    Thanks, best regards,
    Funs Erens | Illuster

    Andy
    Andy
    Keymaster

    Hi,

    I’m sorry to hear you’re experiencing that issue. Could you provide me with your FTP and WP login details please and I’ll investigate this for you.


    Illuster
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Funs,

    I’ve changed the Category name from hey-cyclesto Hey Cycles and it now works as it should. Can you confirm it works for you too?


    Illuster
    Participant

    Hi Andy,

    I don’t understand exactly what you changed. Seems to me that nothing has changed to the category-name Hey Cycles.
    Could you explain this al little bit more…

    Thanks!

    Andy
    Andy
    Keymaster

    Hi Funs,

    If you edit the Gallery, I changed it in the Data Source > Category Name > from hey-cycles to Hey Cycles. I hope that clarifies things?


    Illuster
    Participant

    Thanks, that worked out just fine.


    Lynn Foley
    Participant

    Hi,

    I have the exact same problem after updating to the late July update with the exception that when I open a grid_gallery to check it (or in this case, replace it, since the old ones are now deprecated), and I chose with Data Source to pull the content from the Portfolio, no list of categories shows up. Just a single box. So if I preview the new grid_gallery it seems to pull any or all categories at random (depending on whether or not I check the box), and I have no way to specify which category to use.

    The deprecated/older grid_galleries still work for this even though the category boxes also no longer display for them. Since the correct content still displays in this grid galleries anyway, I’m not changing them until this is fixed, so as not to accidentally mess up the content that displays in all my grid_galleries. They pages have wonky formatting (to be fixed next) but the content is still there, so there’s that.

    I updated to yesterday’s update and it’s the same issue, except the old grid_galleries box no longer has a message about it being deprecated.

    Screenshot of an “old” grid_gallery box showing Data Source with none of my categories displaying
    http://healingfromthecore.com/wp-content/uploads/2015/08/oldgridgallery.png

    Screenshot of a “new” grid-gallery box showing Data Source with same
    http://healingfromthecore.com/wp-content/uploads/2015/08/newgridgallery.png

    Any and all help is, as always, greatly appreciated!
    ~Christy

    Andy
    Andy
    Keymaster

    Hi Christy,

    I believe I’ve found the cause of this.

    Please replace DynamiX/lib/adm/inc/register-post-types.php

    With this file ( unzip ):

    http://help.themeva.com/tmp/register-post-types.php.zip


    Lynn Foley
    Participant

    Yes! That fixed the Data Source/Portfolio/Categories issue! Thanks so much.

    ~Christy

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.