Home / Forums / DynamiX Support / Visual Composer Fatal Error with Update to 5.0.1.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts

  • Lilly
    Participant

    We are getting the following message on every page and post since we have updated to the latest version of DynamiX
    Fatal error: Call to undefined method WPBakeryShortCode_VC_Row_Inner::getShortcode() in /nfs/c06/h04/mnt/97690/domains/blognostics.net/html/wp-content/themes/DynamiX/vc_templates/vc_row.php on line 161

    The Visual Composer is asking for license in Product License so we went ahead and had to purchase the VC. because it was not allowing the update WPBakery Visual Composer with out the license code.
    Now that we have spent another $33.00 to get the plugin the following error code is now gone.

    Fatal error: Call to undefined method WPBakeryShortCode_VC_Row_Inner::getShortcode() in /nfs/c06/h04/mnt/97690/domains/blognostics.net/html/wp-content/themes/DynamiX/vc_templates/vc_row.php on line 161

    We have had issues before with updates but they have always been rectified in the past. We have however never needed to buy a plugin that was bundled with your product.

    Can you please explain why the plugin doesn’t update when the theme updates.

    Lill

    Andy
    Andy
    Keymaster

    Hi Lill,

    You’ll need to update Visual Composer. Please see the guide here: http://help.themeva.com/theme-issues/


    Lilly
    Participant

    Andy, thank you for getting back to us. We are also having a challenge with the shadow and reflection in the Grid Gallery it is to far away from the images the gallery is pulling where do we change the px depth???

    Lill

    Andy
    Andy
    Keymaster

    Hi Lill,

    I knew there was something that slipped through. Can you post your FTP details, along with your WP login details and I’ll fix this directly on your server for you.


    Lilly
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Lilly,

    I couldn’t access the FTP server. However, I’ve created a file for you to upload. Replace the following file:

    DynamiX/lib/inc/grid-gallery-frame.php

    with ( unzip ) this file

    http://help.themeva.com/tmp/dynamix/grid-gallery-frame.php.zip


    Lilly
    Participant

    Andy,

    Thanks that fixed the problem as far as the shadow reflection in the grid-galley. We have a few pressing issues that we aren’t able to come up with any solutions for or work arounds for them.

    Issue 1
    Grid-Gallery is pulling double images on some post but not others Itโ€™s strange, We have noticed that some images that were pulling double donโ€™t always do so. Only those that appear towards the lower part of the post.
    We have gone through the steps of turning off plugins to see if any of those setting are throwing things off which they don’t seem to be doing so,, we have changed the settings in the grid, played around with the preview image etc. but still have had no success in fixing the problem. Outside of the Grid- Gallery area we have under Page Config – Additional set to Archive but it is still pulling duplicate images

    Issue 2
    Grid Gallery spacing between rows are completely wonky and justification of a row is totally to the left, and after the grid layout the following layouts are totally wacked out. Here is an example ( http://blognostics.net/blognostics-an-innovative-experience-in-literature-poetry-and-art/2013/10/24/bn-platinum-poetry-lounge-willow-rose/ ) we have the images set to Image and text with Column Padding Enabled, Excerpt set to 40, depending on what page we are working on depends on how many columns we have the grid set to. Image width and hight also varies depending on the page content we are pulling,

    Issue 3
    Advanced Excerpt isn’t working at all!!! No matter what we try. We have it set to pull 40 words, Exact- Word- Read More- is set to Add read more link to excerpt, but it does not show up, Generate excerpts even if a post has a custom excerpt attached is ticked and useless. The only way we can get text to pull is to add it manually but than the …Read More Link doesn’t work.

    Here is an example of a Grid that we had to tweak(each individual post Excerpt in order to get the lay just about perfect. the Excerpt in each individual post had to set so it is pulling exactly 5 lines otherwise the layout was all over the place.
    http://blognostics.net/platinum-resident-lounges-exclusively-for-poets-creative-writers/
    This we can live but eats up a lot of time…

    Please note that we are in Maintenance Mode until we have these issues fixed or find a work around so you wont be able to see the pages unless you are logged in.

    We do so love love this theme and all of the dedication you have put into making this the best template out there ๐Ÿ™‚


    Lynn Foley
    Participant

    Hello Lilly and Andy!

    I have a similar challenge in regards to Issue #2 posted above. (I think I do anyway, since I can’t see it atm.) The grid gallery column width default is not as wide as the container, resulting in tons of white space on either side – and nothing I change in the grid_gallery settings seems to affect it. See http://healingfromthecore.com/resources/ or http://healingfromthecore.com/products/ to see what I mean.

    (Also – is there a way to reduce the padding around the text in the tabs themselves? With the new tabs, which are lovely, on a desktop browser our tabs now go into two rows. Not sure how we can shorten our labels/words any more in order to get them back up onto the same line. Is there an option I’m missing somewhere?)

    Thank you!
    ~Christy

    Andy
    Andy
    Keymaster

    Hi,

    For some reason my post did not work.

    1. This would indicate that “First Image Detection” is on via Appearance > Theme Options > General > First Image Detection.

    2. The column padding controls the padding between the Grid elements, if you have this turned on, it will create white space.

    3. It’s strange Advanced Excerpt isn’t working. In order for it to function at all, all manual post excerpts have to be removed because if a post excerpt is available, it will use that instead.


    Lilly
    Participant

    ACODA and ANDY

    Your help is needed to rectify the problems that we are having with the grid gallery pulls, the duplicate images and the AE not pulling Excerpt properly

    We did as ACODA suggested in General options and ticked First Image Detection, It worked for some of the grid gallery posts but not for all. We also went as far as making sure the settings were exactly the same of each post/page and it made no difference poages/ and post are sill pulling dup images

    Example of working Grid
    https://www.dropbox.com/s/35f08f0cj8tfbab/Screen%20Shot%202015-08-17%20at%2012.02.39%20PM.png?dl=0

    Example of non working Grid

    https://www.dropbox.com/s/49yp48xipi1x7l4/Screen%20Shot%202015-08-17%20at%2011.59.11%20AM.png?dl=0

    All have the same settings

    As far as AE we have the option Generate excerpts even if a post has a custom excerpt attached is ticked and useless. Your solution ACODA is basically to go into over 600+ post and pages to remove the excerpts which is not do able do to time constrains. It was working perfectly prior to the update.

    Your help is needed ASAP so we can get the site up and running for our clientele…

    Andy
    Andy
    Keymaster

    Hi Lilly,

    Sorry for the confusion over ACODA vs Andy, they’re both me. ๐Ÿ™‚

    I’ve done some tweaking to the Advanced Excerpt and believe that’s working much better now. The only thing that is creating the different heights is the images with a different aspect ratio – unfortunately there isn’t a lot that can be done about this as the image resizing script retains the original ratio of the image.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.