Home / Forums / ePix Support / Visual Composer in conflict with the Epix Theme

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts

  • Peter Stanbury
    Participant

    Hi
    I have contacted the WP Bakery people about how the Visual Composer crashes my website every time I activate the VC plugin. I always delete the plugin everytime I have to upgrade because that is they way they insist it is done. Over the last week or so I have waited for them to fix the bugs in the VC and evey time I renew my attempt to upgrade. It crashes and I revert to the earlier version of the plug in. Today i thought it was time I contacted them to say things were not improving. THis is the reply I had and I do not fully understand what is meant. Can you advise.

    WP BAKERY WROTE:
    “There is an inbuilt version of visual composer present in your theme which is overriding the standalone plugin version and hence causing the issue. You will have to get rid of the inbuilt version. I would advise you to do so with the help of theme author, otherwise you might loose the extra elements added by him. Once this is done, you can install the standalone plugin and it will work fine.”

    They seem to be suggesting there is another version of VC inside the theme already that is in conflict with the new version upgrade. Can you advise what can be done?

    Peter


    Tom ( Support)
    Keymaster

    Hi Peter,

    The versions of Visual Composer bundled with the theme are modified versions to be used with the theme. The official versions from VC will not work with the theme as they are riddled with bugs and do not include all of the extra options.

    The current latest version as of this afternoon is 4.2.1, but a new version is coming very soon that will be bundled with the theme.

    Once the new update to the theme is out, you can update VC by going to Plugins > Deactivate VC > Delete it > Admin notice at the top of the WP Admin, click install Visual Composer > You should now have the latest version.

    Kind regards,
    Tom


    Peter Stanbury
    Participant
    This reply has been marked as private.

    Mark Korecz
    Participant

    Hi Tom,

    I have quite the same problem. I have fresh and brand new WordPress install, I have fresh and latest ePix install filled up with demo data. For the first time I could not use the real time theme customization (blank page appears only instead of the theme editor). I turned off Visual Composer then the customization worked well. After I finished I activated VC again.

    The problem is that I cannot edit any of the Pages on my site. Only blank page comes when I try to edit any of my pages. When I deactivate VC, the page editor works well but in this case obviously I cannot use the benefits of the Visual Composer.

    What can be the problem?

    (History: I already have had a working live site with old ePix theme. I could not upgrade it to a newer version automatically so I downloaded the newest ePix and installed on my site. I just wanted to build my site from ground zero again since every settings disappeared with the new installation. The system did not allow me to edit the site because it needed a newer version of Visual Composer. I could not upgrade VC through my admin site so I had to purchase the VC separately. I did it, I installed it which resulted a total site crash, both front-end and back-end sites were unavailable. I could not do anything else than deleting my whole live website from the server, drop every tables from MySQL database and do a brand new WordPress and ePix install. From this point the issue is described above.)

    Andy
    Andy
    Keymaster

    Hi Mark,

    Once you’ve installed the latest version of ePix, you can update VC by following this guide here: http://help.themeva.com/theme-issues/

    Let me know if that resolves the issue or not. If not, please post your WP login details and I’ll take a look as to why that maybe happening.


    Mark Korecz
    Participant

    Hey Andy,

    thank you for the quick reply. I have the latest version of ePix and the latest version of VC. My site says everything is up to date and offers no upgrade on theme or plugin. No other plugins are used on the site it is absolutely ‘virgin’ besides the demo data of ePix.
    (Shall I mark my reply to private to give you the login details?)


    Mark Korecz
    Participant

    Hi Andy,

    the thing is that I have had a totally different notion about Visual Composer until now. I had a one year old ePix and VC before I started this whole upgrade process, and Visual Composer was totally different in the past as I remember (I did not refreshed my portfolio website for almost one year). So the thing is that I noticed that I shall not use “Edit” option in my admin site for pages rather I need to use the link “Edit in Visual Composer”. Previously there was no such an option, that is why I have not noticed this possiblity until now.
    Like this, Visual Composer works well however it is a totally new surface, a new tool for me, so I need to discover it. So it seems, problem solved (I hope).

    All the best,
    Mark

    Andy
    Andy
    Keymaster

    Hi Mark,

    No problem, if you have any more questions, just ask.

    Kind regards,
    Andy


    Mark Korecz
    Participant

    Dear Andy,

    after two days of working with my website it turned out that the Visual Composer does not work properly.
    Phenomenons:
    – When VC plugin is activated, I cannot use the regular back-end editor for pages. Only blank page comes in when I try to use it. When VC is deactivated, back-end editor works well.
    – When I create a new empty page, I can edit it with Visual Composer. But after the page contains several elements like parallax background, text blocks, embedded gallery sliders or pie charts I cannot edit it with VC anymore. When I click on Edit with Visual Composer, only a white blank page comes in. Because of this I have to do all my pages from ‘level zero’ to full complete at once, othewise I cannot edit or modify it later. That is not quite convenient.
    – It happened that I tried to embed two group sliders on one page. The first slider appeared, the second was not. I tried to clone the first in order to try it, but not helped. The first slider was okay, but there was only blank space at the place of the second one (both in the editor and the front-end live site).
    – I tried to put in single images in a page with circle effect on them and make them links to other certain pages. I do not know why but these images do not work like links, I cannot click on them although there is the URL in the HTML code of the page.
    – I tried to put in Pricing Table on one page but I cannot edit them. In the window of Pricing Table Settings there are only to options: number of columns and Extra class name. How can I edit the table’s heading, how can I add and edit the list items, how can I modify the color of the pricing table?

    That’s all for now.
    I have WordPress 4.2.1, ePix 1.4.3, Visual Composer 4.4.4 (bundled with ePix). I use no other plugins.

    I saw in the Troubleshooting Guide that these issues can be PHP memory problems. As I see in PHPMyAdmin my website has 50MB PHP Memory limit, those suhosin values are on 1000 at the moment. I asked my hosting service provider to increase suhosin values, but they told me that I need a higher priced premium service package to increase them. Actually I find it very strange that this hosting service I use now is not enough for a wordpress page. I have used ePix template on my site for a year now without any problem until today. I have a Joomla-based classifieds website at the same hosting service too, that works also seamlessly with these settings. How can it be that I upgrade my ePix template to a newer version, and now my hosting service is not enough?
    If the premium service is the sole solution for my problem, then I will order it of course, but at the moment I am not sure that this causes my problem.

    Pls help.

    All the best,
    Mark

    • This reply was modified 2 years, 9 months ago by  Mark Korecz.
    Andy
    Andy
    Keymaster

    Hi Mark,

    Have you tried increasing the WordPress memory. This WordPress memory isn’t the same as the PHP memory limit. It’s set within the /wp-config.php file on your server. See the wordpress guide here: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    I’d set it to 96mb and see if that works.

    If you still have issues, please post your WP and FTP details and I’ll take a look for you.


    Mark Korecz
    Participant
    This reply has been marked as private.

    Mark Korecz
    Participant

    Also please tell me where can I translate the ‘Load more’ button in the Grid galleries and also the ‘Name’ and ‘Email’ field names and ‘Send’ button in the contact forms. Po/Mo files do not affect these. Thx

    Andy
    Andy
    Keymaster

    Hi Mark,

    I can’t see anything wrong with your setup – it is an error 500 that happens, which is a server issue. It does appear to be the typical white screen of death, but the WP memory isn’t resolving it.

    Out of all of the support I’ve done, I’ve not come across this. I can almost guarantee that if you installed onto another server you wouldn’t have this issue.

    Did you hosting come back to you about the suhosin value? Is there another server you can test, just as proof to your hosting it’s a server issue?

    Andy
    Andy
    Keymaster

    Hi Mark,

    I can’t see anything wrong with your setup – it is an error 500 that happens, which is a server issue. It does appear to be the typical white screen of death, but the WP memory isn’t resolving it.

    Out of all of the support I’ve done, I’ve not come across this. I can almost guarantee that if you installed onto another server you wouldn’t have this issue.

    Did you hosting come back to you about the suhosin value? Is there another server you can test, just as proof to your hosting it’s a server issue?

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.