Home / Forums / DynamiX Support / Visual Composer mess my web site after a migration!

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts

  • Giuseppe
    Participant

    Hello, I just updated to the 4.0.8 version, after having migrated a backup copy of my web site I’ve got an error message: “Warning: set_time_limit() has been disabled for security reasons in […]/htdocs/wp-config.php on line 90”
    I tried to edit it with no result. When I deactvate the Visual Composer the web site is accessible again with all of the shortcodes not visible! I tried also to delete .htaccess with no result.
    How to fix it pls? Thank you.

    Regards,
    Giuseppe


    Giuseppe
    Participant

    Bye the way, I forgot to report that no issue when I installed a localhost of the same backup copy of the web site.


    Giuseppe
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi,

    It sounds like your hosting provider has turned off the feature that the plugin uses in order to ensure it doesn’t just fail when processing large sites.

    From what I have read online, contacting your hosting company with the error message usually works for people as the host can modify the files that are preventing this. You’ll need to contact your host to ask them if they’d be willing to lift that PHP function restriction.

    Hope this helps.
    Tom


    Giuseppe
    Participant

    Hello, thank you for your answer; I wonder what is the exact name of the PHP limit restriction you meant please 🙂
    Thank you.

    Regards,


    Giuseppe
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi,

    Are you sure you removed the correct bit of code? The site does not seem to be there anymore? Did your hosting company mention anything else about this?

    Tom


    Giuseppe
    Participant

    Hello, the web site is still there with its blank page; the hosting company told me to reinstall wordpress from its script option. After doing it the issue is not fixed.

    Regards,


    Giuseppe
    Participant
    This reply has been marked as private.

    Giuseppe
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    It looks like your WordPress install is running out of memory when Visual composer is active. Please follow the steps below to test if upping the server limit sorts this problem.

    Some hosting companies set their memory limit very low so you just need to up the memory on your install.

    Please follow the WordPress memory guide here.

    If that doesn’t work, try upping you suhosin value value on your server. You will need to ask your hosting company to increase to the following suhosin value:

    suhosin.post.max_vars = 5000
    suhosin.request.max_vars = 5000

    Kind regards,
    Tom


    Will Hampton
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Will,

    Are you using the latest version of DynamiX and Visual Composer prior to updating? If the site is coming up blank, this means that your server is running out of memory. If you do what was mentioned above, this should solve things.

    As you are using a very outdated version of DynamiX, this will be why your site is erroring out. You need to update the theme to be able to use the latest version of Visual composer. Please do not use the official version of Visual Composer as it is riddled with bugs. The latest update of Visual Composer is always bundled with the theme and has many other options added with the theme.

    A new update has been released for DynamiX which contains the latest version of Visual Composer too.

    For more information on updating the theme, please see here.

    Once updated, you can update VC by go to Plugins > Deactivate VC > Delete it > Appearance, Install Plugins, click install Visual Composer > You should now have the latest version.

    Then reset your browser cache and websites cache (if you have a cache plugin installed).

    Hope this helps.

    Kind regards,
    Tom

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.