Home / Forums / ePix Support / Waring after Visual Composer Install

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts

  • Bill Morris
    Participant

    After installing activating then deleting and re-installing the Visual Composer I am getting this Warning about 10 lines of this

    Warning: Illegal string offset ‘param_name’ in /home/mangoman/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 71

    Warning: Illegal string offset ‘param_name’ in /home/mangoman/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 73

    Warning: Illegal string offset ‘param_name’ in /home/mangoman/public_html/wp-content/plugins/js_composer/composer/lib/mapper.php on line 71


    This shows up in the Admin and on the site itself —

    How do I fix this? -not a good start for a new theme.


    Tom ( Support)
    Keymaster

    Hi,

    Your server is probably running PHP 5.4 with strict error reporting switched on. Visual Composer shows up a few small errors when PHP 5.4 is used on your site. It does not do any damage and should work as normal.
    You can disable the warnings in this guide here. If you are unsure of how to do this, I recommend contacting your hosting company as they should be able to assist.

    Hope this helps.

    Kind regards,
    Tom


    Bill Morris
    Participant

    Hi .. I need a little more help then this .. I’m not a coder .. my hosting company said I need to create a file but couldn’t tell me what to put in it? Please be more detailed.

    Honestly – of the 20 or so themes I’ve purchased – I’ve never had this issue .. seems like something that could be fixed on your end or the plugin developers side – through an update – or use a different plugin.

    I really like the theme .. but may need to get a refund …

    Thanks,
    Bill


    Tom ( Support)
    Keymaster

    Hi Bill,

    Which version of ePix are you currently using? If it is not the latest 1.0.2, please update prior to reading below. If that resolves things, there is no need to provide the information asked below.

    If things are not resolved, please can you reply with your login details and FTP details and we will get this resolved for you ASAP. Please set your reply to private also.

    Kind regards,
    Tom


    Bill Morris
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Bill,

    The FTP directory doesn’t go anywhere.

    I’ve already mentioned this to the Visual Composer developers before and thought they had implemented the fix, however it turns out they haven’t.

    This is the file that needs to be replaced on your FTP.

    Locate: /wp-content/plugins/js_composer/composer/lib/mapper.php

    Unzip and Replace With: http://help.themeva.com/tmp/mapper.php.zip


    Barbara
    Participant

    Hi there, I experience the same problem as mentioned above, and did as suggested (change php.ini and updated mapper.php), but I still get the errors linked to the Visual Composer. In the backend it also mentioned that a new version is available, but I’m unable to update. What should I do here?


    Eric Deschenes
    Participant

    I’m also having the same problems. Plus I can’t see the WYSIWYG options when adding a text block of anything else that involves text styling.

    Those issues are pretty annoying !!!


    Tom ( Support)
    Keymaster

    Hi,

    @xive, Please can you reply with your login details so I can take a further look into this? Please set your reply to private also. There is a newer update for Visual Composer and I will be included in the next version of ePix.

    @delirium27, I have replied to your other thread regarding this.

    Hope this helps.

    Kind regards,
    Tom


    Barbara
    Participant

    Hi Tom,

    I’m still working local on a xampp server, through localhost. So it will be quite hard to take a look at it. Do you have other suggestions? When is the next version due? Hopefully with this update the issue could be resolved…

    Andy
    Andy
    Keymaster

    Hi Barbara,

    Make sure you’re using the latest ePix version – then delete the version of Visual Composer currently in your Plugins area – this will tell you to install the plugin ( via a purple message ). Once this has installed, apply this:

    Locate: /wp-content/plugins/js_composer/composer/lib/mapper.php

    Unzip and Replace With: http://help.themeva.com/tmp/mapper.php.zip


    Barbara
    Participant

    It seems to work now. Perfect! Thanks


    Minpla
    Participant

    Hello,

    Today I had the same problems. Solved with your instructions.

    Thank you very much.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.