Home / Forums / ePix Support / Warnings showing after activating theme

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts

  • joycakuijpers
    Participant

    Hi,

    I have installed WordPress locally and have activated the ePix-theme. Since I had activated it, it is showing multiple warnings:

    ( ! ) Notice: Undefined variable: labels in /Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-content/themes/ePix/lib/adm/inc/register-post-types.php on line 36
    Call Stack
    # Time Memory Function Location
    1 0.0052 337464 {main}( ) ../index.php:0
    2 0.0058 397240 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-admin/admin.php’ ) ../index.php:10
    3 0.0060 412600 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-load.php’ ) ../admin.php:31
    4 0.0062 422104 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-config.php’ ) ../wp-load.php:37
    5 0.0072 502608 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-settings.php’ ) ../wp-config.php:81
    6 0.3284 31580416 include( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-content/themes/ePix/functions.php’ ) ../wp-settings.php:329
    7 0.3595 34204992 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-content/themes/ePix/lib/adm/inc/register-post-types.php’ )

    ( ! ) Notice: De aangeroepen constructor methode voor WP_Widget is verouderd sinds versie 4.3.0! Gebruik

    __construct()

    in plaats daarvan. in /Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-includes/functions.php on line 3457
    Call Stack
    # Time Memory Function Location
    1 0.0052 337464 {main}( ) ../index.php:0
    2 0.0058 397240 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-admin/admin.php’ ) ../index.php:10
    3 0.0060 412600 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-load.php’ ) ../admin.php:31
    4 0.0062 422104 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-config.php’ ) ../wp-load.php:37
    5 0.0072 502608 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-settings.php’ ) ../wp-config.php:81
    6 0.4083 35929760 do_action( ) ../wp-settings.php:353
    7 0.4175 35942360 call_user_func_array:{/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-includes/plugin.php:503} ( ) ../plugin.php:503
    8 0.4175 35942536 wp_widgets_init( ) ../plugin.php:503
    9 0.4186 35984056 do_action( ) ../default-widgets.php:1649
    10 0.4187 35988248 call_user_func_array:{/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-includes/plugin.php:503} ( ) ../plugin.php:503
    11 0.4187 35988312 load_mini_gallery( ) ../plugin.php:503
    12 0.4187 35988400 register_widget( ) ../custom-widgets.php:14
    13 0.4187 35988448 WP_Widget_Factory->register( ) ../widgets.php:720
    14 0.4187 35988664 Mini_Gallery_Widget->Mini_Gallery_Widget( ) ../widgets.php:591
    15 0.4187 35990168 WP_Widget->WP_Widget( ) ../custom-widgets.php:34
    16 0.4187 35990416 _deprecated_constructor( ) ../widgets.php:176
    17 0.4188 35990904 trigger_error ( )

    ( ! ) Notice: De aangeroepen constructor methode voor WP_Widget is verouderd sinds versie 4.3.0! Gebruik

    __construct()

    in plaats daarvan. in /Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-includes/functions.php on line 3457
    Call Stack
    # Time Memory Function Location
    1 0.0052 337464 {main}( ) ../index.php:0
    2 0.0058 397240 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-admin/admin.php’ ) ../index.php:10
    3 0.0060 412600 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-load.php’ ) ../admin.php:31
    4 0.0062 422104 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-config.php’ ) ../wp-load.php:37
    5 0.0072 502608 require_once( ‘/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-settings.php’ ) ../wp-config.php:81
    6 0.4083 35929760 do_action( ) ../wp-settings.php:353
    7 0.4175 35942360 call_user_func_array:{/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-includes/plugin.php:503} ( ) ../plugin.php:503
    8 0.4175 35942536 wp_widgets_init( ) ../plugin.php:503
    9 0.4186 35984056 do_action( ) ../default-widgets.php:1649
    10 0.4231 35991336 call_user_func_array:{/Users/joycakuijpers/Documents/Websites/manouktest.dev/wp-includes/plugin.php:503} ( ) ../plugin.php:503
    11 0.4231 35991400 load_nv_contact_form( ) ../plugin.php:503
    12 0.4231 35991480 register_widget( ) ../custom-widgets.php:689
    13 0.4232 35991528 WP_Widget_Factory->register( ) ../widgets.php:720
    14 0.4232 35991744 nv_contact_form->nv_contact_form( ) ../widgets.php:591
    15 0.4232 35993216 WP_Widget->WP_Widget( ) ../custom-widgets.php:708
    16 0.4232 35993376 _deprecated_constructor( ) ../widgets.php:176
    17 0.4233 35993728 trigger_error ( )

    I hope you understand any of it since the main warnings are in Dutch and also that you can help me fix it.

    Andy
    Andy
    Keymaster

    Hi,

    Some of those warnings are from WordPress itself and can’t be changed. They are warnings and once WP_Debug is switched off, they won’t display.


    joycakuijpers
    Participant

    Hi,

    thanks for your answer. I’ve tried to switch it off but the warnings remain visible.

    define(‘WP_DEBUG’, false);
    define(‘FS_METHOD’, ‘direct’);


    joycakuijpers
    Participant

    Turns out the debug-mode was enabled in the local hosting program I use. I’ve disabled it now and the warnings are gone.

    Thanks for the help!

    Andy
    Andy
    Keymaster

    You’re welcome, I’ll remove the warnings that I can for the next version regardless 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.