Home / Forums / DynamiX Support / Widget rendering differently when placed in sidebar vs footer

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts

  • Scott C
    Participant

    Hello,

     

    http://ohc.scottyshideout.com/emeritus/

     

    Can anyone please help me figure out why the RSS widget I have in the 1st column of my footer is rendering differently than the same exact widget placed in the sidebar? I’ve tried to inspect the code… the only difference i can find is the ID, but as to where any CSS rules come from is a mystery to me.

     

    I’m not sure if that is even what’s causing the problem.

     

    You’ll notice in the footer, there are “>” symbols to the left of each listing–there are also line breaks between each listing. These are both not present in the same widget in the sidebar.

     

    Thanks for any help, i’ve been banging my head against a wall trying to figure this out.

    Andy
    Andy
    Keymaster

    Hi,

     

    The sidebar styling is slightly different. Try adding the following to Header Settings -> Custom CSS.

     

    .sidebar-content .widget li a {

    padding:8px;

    padding-left:15px;

    }

    .sidebar-content .widget li {background:url(images/break-a.png) top left repeat-x;padding:0;}

    Scott C
    Participant

    I tried that code in the Skin settings > Custom CSS (there was only custom HTML area in the Header Settings). It changed the appearance, but it did not make it look like the menus in sidebars nor in the footer… the “>” at the beginning was still missing.

     

    Is there an update of dynamix where there is custom css in the header settings?


    Scott C
    Participant

    I checked my version and it looks like i’m on the same version of Dynamix that is available from themeforest. Does this mean i’m up to date?

     

     

    Andy
    Andy
    Keymaster

    Hi Scott,

     

    It looks like my reply went missing. I meant Skin Settings đŸ˜‰

     

    It doesn’t look like the CSS I provided is present on your site at the moment, did you remove it again?

     

    You’ll also need to add the following to .sidebar-content .widget li a

     

     

     

    so all together it should look like

     

    .sidebar-content .widget li a {

    padding:8px;

    padding-left:15px;

    background:url(/wp-content/themes/DynamiX/stylesheets/images/li-arrow.png) center left no-repeat;

    }

    .sidebar-content .widget li {background:url(images/break-a.png) top left repeat-x;padding:0;}

     


    Scott C
    Participant

    Hey Andy–yes i did remove it because i wasn’t sure if it was in the right place.

     

    I’ve put it back now, and actually had to do a little digging and tweak the code you gave me.

     

    The li-arrow.png you mentioned i don’t have in that directory (not sure why..), but i traced the path of the arrow which is currently used in the sidebar widget menu and used that (/wp-content/themes/DynamiX/images/li-arrow-drk.png).

     

    Something in the provided code still isn’t making the linebreaks show up right… it actually removed them from the menu widget.

     

    It’s getting close, please advise!

     

    Andy
    Andy
    Keymaster

    My apologies, I’m writing it from style.css change the following.

     

    images/break-a.png

     

    to

     

    /wp-content/themes/DynamiX/images/break-a.png


    Scott C
    Participant

    Ah thanks for that!  There was still one thing off, but I was able to track down the difference and add display:block; to the .sidebar-content .widget li a selector…

     

    Here’s the code in 100% working condition! Thanks again for your help =D

     

    .sidebar-content .widget li {
    background:url(/wp-content/themes/DynamiX/images/break-a.png) top left repeat-x;
    padding:0;
    }
    .sidebar-content .widget li a {
    padding:8px;
    padding-left:15px;
    display:block;
    background:url(/wp-content/themes/DynamiX/images/li-arrow-drk.png) center left no-repeat;
    }

     

    See it working: http://www.ohc.scottyshideout.com/emeritus

     

    Cheers!

    Andy
    Andy
    Keymaster

    Thanks for the follow up – I’m glad it’s all working now đŸ˜‰

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.