Home / Forums / DynamiX Support / Wp-ECommerce Problems – sidebars and skins

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts

  • Jeff
    Participant

    Hello,

    I added a new SideBar (3) and applied it to my Products Page for WP-ECommerce. I also changed the skin defaults in the Dynamix page settings to have different colors in my store.

    The sidebar is showing Sidebar1, not Sidebar3. I've updated the page and verified the settings.

    For the colors, when I load the main products page, the new colors show up. When I go to a product detail page, the old colors show up.

    Another quick note – there's no styling on the ShareThis link/image in the product detail page. Can't really see it when the inner theme is dark.

    http://www.blogsforexpats.com/digital-downloads/

    Thanks,

    Jeff


    Jeff
    Participant

    Something is definitely messed up here. If you look at the product detail page now, you only see the Product Title and the first part of the description:

    http://www.blogsforexpats.com/digital-downloads/online-marketing-ebooks-guides/top-affiliate-tactics/

    I've tried all the various combinations in Store settings, like turning off the Cats in the URL, diffrerent views, and so on. The only thing that works is the main product page.

    Using Firebug, I can see that all requests are answered successfully – no hidden 404s, no javascript errors.


    Jeff
    Participant

    I've also deleted and recreate the page – full delete, not just "trash", with no change in the result..


    Jeff
    Participant

    Just realized the same thing is happening in Forums (BBpress). Similar, anyway.

    The main forums page is set to use SideBar1. The main forums page is correct.

    Subsequent pages, like the categories and sub-forums and topics are all showing SideBar2.

    Andy
    Andy
    Keymaster

    Hi Jeff,

    The layouts are inherited by the layout set in the Blog Settings page – a future update I'll add the option to define this separately. 

    What plugins do you currently have activated – there are a tonne of extra calls which shouldn't be needed. 

    BBPress layout/sidebar is defined in DynamiX Menu -> General Settings when the plugin is activated. 


    Jeff
    Participant

    I've turned every plugin off and still have the same problems. The bigger problem is from my post #2 – only the title and the first part of the description is showing – no add to cart, by now, read more, nothing.

    Wait – even though I set a sidebar in the page for WP-Ecommerce (their productpages), it uses the layout set for blogs?

    I set the correct sidebar in DynamiX ->General for BBPress, and in the Forum page definition. It works on the main forum page, but all subsequent links get the other sidebar.

    Andy
    Andy
    Keymaster

    Can you email me your WP login detials and I'll see what is going on with the products. 


    Jeff
    Participant

    Sent in PM – thank you

    Andy
    Andy
    Keymaster

    Hi Jeff,

    Annoyingly when there is a sidebar active it will knock out the product information. If I change the blog settings to full width it will display the product fine. I'm not sure if there is something in the sidebar causing this but I tried the 3 different sidebars you have and the same result occurred. 

    I'll work on this over the next couple of days and get a resolution to the issue (completely bizarre though…). 

    Andy
    Andy
    Keymaster

    I've just tested on this server and another and it does seem to be related to something in the sidebar…. I've tested with just categories in the sidebar and it displays the product information fine. 


    Jeff
    Participant

    I changed mine to full width, and it's still happening. Of course, my store is showing the blog sidebar when you are in categories or product details.

    Now my Forums are showing the Blog side bar once you leave the main forums index.

    This is crazy..

    Andy
    Andy
    Keymaster

    I'm going to setup a few tests over the next few days – I have a few setups working perfectly so there is something interfering. Definitely something in the sidebars which are causing the product information not to show but why they would do that is bizarre. 


    Jeff
    Participant

    When you say the theme supports BBPress, are you talking about the plugin, version 2.02?

    Andy
    Andy
    Keymaster

    Yes that's right. I introduced the support for it in DynamiX 2.8.7. 

    Andy
    Andy
    Keymaster

    Can you provide a list of the widgets you're using in your sidebars please?

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.