Home / Forums / DynamiX Support / WP SyntaxHighliter problem

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts

  • David
    Participant

    I am using the Dynamix theme with the plugin WP SyntaxHighlighter and the output is not format properly. If I use the plugin with other theme the ouput is well formated. As an example if I enter the following

    <pre class="brush: csharp; gutter: true">public class ShowOnMap {}</pre>

    the output will be

    public

    class

    ShowOnMap {}

     

    Each word will use a line. 

     

    Andy
    Andy
    Keymaster

    Hi David,

    Do you have a link so I can the actual output and I'll post the fix. 


    David
    Participant

    Hi Andy,

    Here's the link showing the problem: http://davidbrillon.com/?p=113

    Andy
    Andy
    Keymaster

    Hi David,

    If you edit style.css and search for pre {

    remove the following line and it should resolve the issue display:block;


    David
    Participant

    Hi Andy,

    I cannot find this line in style.css assign to a pre.

     


    David
    Participant

    Hi Andy

    I removed the line from the code tag instead of the pre tag (witch di not contain the display:blocks; parameters) and it seems to work.  Will this affect other parts of the theme?

    Thanks.

    Andy
    Andy
    Keymaster

    If that works it should be okay – as long as it's just for code and doesn't contain any other tags in the style e.g. code, p, div etc

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.