Home / Forums / DynamiX Support / wpbakery visual composer keeping pages from loading

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • Sir Ryan the Great
    Participant

    I am having issues with two of my pages loading on my site. Through extensive troubleshooting we boiled it down to the visual composer plugin. Every time I attempted to load the pages below it would either be completely blank or throw an internal server 500 error (both Chrome and IE). I disabled the plugin and now everything loads fine but as it is integral to the theme’s makeup, many of my elements on all pages are not showing correctly. I have re-enabled the plugin as having two pages down is better than the whole site not looking right.

    I am running version 4.1 of the visual composer, 3.6 of WordPress, and 4.0.4 of Dynamix

    http://www.creeksidechristian.com/students/high-school
    http://www.creeksidechristian.com/students/middle-school


    Tom ( Support)
    Keymaster

    Hi,

    First thing I recommend doing is updating WordPress, DynamiX and Visual Composer as this should solve all of your issues straight away.

    A new update has been released for DynamiX which contains the latest version of Visual Composer too.

    For more information on updating the theme, please see here.

    Once updated, you can update VC by go to Plugins > Deactivate VC > Delete it > Appearance, Install Plugins, click install Visual Composer > You should now have the latest version.

    Then reset your browser cache and websites cache (if you have a cache plugin installed).

    If you are still having issues, please set your reply to private and provide your URL/login details so I can take a further look for you.

    Hope this helps.

    Kind regards,
    Tom


    Sir Ryan the Great
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi,

    I have found the issue. A blank screen or 500 error means that your server memory limit has been maxed. Since DynamiX is a very powerful WordPress theme and features a tonne of advanced plugins, it uses more memory than the standard inferior themes.

    Some hosting companies set their memory limit very low so you just need to up the memory on your install.

    Please follow the WordPress memory guide here.

    If that doesn’t work, try upping you suhosin value value on your server. You will need to ask your hosting company to increase to the following suhosin value:

    suhosin.post.max_vars = 5000
    suhosin.request.max_vars = 5000

    Kind regards,
    Tom


    Sir Ryan the Great
    Participant

    Awesome, I will try this change and see if this works. I appreciate your help!

    Just so I am clear, I need to define the WP_MAX_MEMORY_LIMIT in the wp-config file before wp-settings is referenced? And is the max 256 overkill for our needs?


    Tom ( Support)
    Keymaster

    Hi,

    You can change that also, but I normally just add define( ‘WP_MEMORY_LIMIT’, ‘xxM’ ); in the wp-config.php file. 256 is not overkill as some plugins can use a lot of memory when they are functioning.

    Hope this helps.
    Tom

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.