Home / Forums / DynamiX Support / Z index on menu not working in IE 11

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts

  • Sandra P
    Participant

    I have noticed that the main sub menu hides behind my flash object on my homepage in IE11. This is normally fixed with the z-index. Can you suggest where i can fix this. Thank you

    Here is the homepage http://vacationrentalsbyrealtor.com


    Tom ( Support)
    Keymaster

    It’s fine in IE10, somehow they have managed to mess it up in IE11! They did the same for IE7, fixed it in all the other versions and have now messed it up again.

    Please try the following CSS to see if this fixes things. Add it to Appearance > Theme Options > Customize > Custom CSS.

    .entry object {z-index:0;}
    

    Kind regards,
    Tom


    Sandra P
    Participant

    Thank you for the help. This did not resolve the issue. Menu is still behind flash object in IE 11.


    Tom ( Support)
    Keymaster

    Hi,

    I have just tested this on my dev server with your flash file and IE11 and it works if you insert it via the Video Player element via Visual Composer and select Flash. This should display it properly in IE11.

    Please let me know how you get on.

    Kind regards,
    Tom


    Sandra P
    Participant

    Thank you. It solved the menu issue. But, i am now having an issue where it does not display the width and height correct. It is shrinking the height. I have tried both settings (16:9 and 4:3). My file is 600×600. Do i need a 1×1 ratio?

    Here is how it should look
    http://vacationrentalsbyrealtor.com/

    Here is how it looks using the video player plugin
    http://vacationrentalsbyrealtor.com/flash-test/


    Tom ( Support)
    Keymaster

    Hi,

    Please try adding the following code to Appearance > Theme Options > Customize > Custom CSS.

    .page-id-5221 .videowrap.four_by_three {
    height: 600px !important;
    }
    

    When adding it to the home page, use this code.

    page-id-4983 .videowrap.four_by_three {
    height: 600px !important;
    }
    

    Hope this helps.

    Kind regards,
    Tom


    Sandra P
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Sandra,

    It is really not recommended to use Flash content on your site as Flash does not work with any mobile or tablet devices.

    Regardless, the flash content does not seem to show on your site. You have 7 or so errors relating to the flash files. Failed to load resource.


    Sandra P
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi,

    Your site does not seem to have the sticky menu turned on so at the moment the flash is not covering the menu.

    I mean on a mobile/tablet the flash will not show.

    The menu is set to a high z-index, the plugin should not be set as high as it is if it is interfering. Can you not add the flash code via the HTML element within Visual Composer?

    Kind regards,
    Tom


    Sandra P
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Sandra,

    The sticky menu is not on so I cannot see the issue of the menu going behind the flash content at the moment so I cannot provide any code for this currently.

    Kind regards,
    Tom


    Sandra P
    Participant
    This reply has been marked as private.

    Sandra P
    Participant
    This reply has been marked as private.

    Sandra P
    Participant
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.