Home Forums ePix Support Could you please check my site's speed?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #98228

    toddles_
    Participant

    Hi there,

    SITE: http://vividimages.com.au/

    The client who I have built this site for has told me that it takes a really long time to load. When I test the speed on a speed testing site, it says between 4-5 seconds. She is saying it takes about 20 seconds.

    The home page is 1.7MB (too big?). I have optimized the images as best as I know how.

    She also said “Also I am on website and it is spinning saying “waiting for available socket”” – is this a Chrome issue?

    I’d love some advice,

    Thank you!
    Karen

    #98240
    Edcel
    Edcel
    Moderator

    Hi @toddles_

    1.7MB is actually not too big and should be good enough for a site with a number of images, but if you can optimize the images further that will help.

    Adding caching to the site will also help improve speed.

    For the message he saw, that is likely an issue with his Chrome. Is the site’s speed the same if he uses Firefox?

    Regards.

    #98263

    toddles_
    Participant

    I will have her check on Firefox, thanks.

    Suggested plugins for Caching? 🙂

    Thanks in advance!

    #98267
    Edcel
    Edcel
    Moderator

    Hi @toddles_

    You can use any plugin like WP3TC, WP Super Cache or WP Rocket but it is best to coordinate with hosting provider as they have preferred plugin for caching.

    Regards,

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

© 2019 Acoda