Home Forums ePix Support Disable resizer for thumbnails, but not for images

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #44882

    A D Birch
    Participant

    Hello,

    I utilize grid galleries created via portfolio categories, high-res images (2400 x 1800 px on average) and lightbox via the Epix theme.

    When I click an image, the lightbox opens at 800×450 regardless of monitor size, and when I right-click to look at the original image, it’s the image with the suffix “800×450” on the end. It’s been resized. Is this is a setting *I* have wrong in the theme, or did I upload improperly, or is it the fault of the resizer utility? On the demo, on the grid gallery, the images are linking to the original image, not a resized version, yet mine are.

    What have I done incorrectly? I greatly prefer to use portfolio/categories for uploads, as I am able to order them by the date they were uploaded which is an important feature that slide sets do not allow for.

    Please advise, thank you.

    AD

    #44891

    A D Birch
    Participant

    Addendum: Slide Set images work exactly as I want them to. You click an image, it opens to around the proportion of the screen size. You right click, view image, and there it is, original size.

    Portfolio images, on the other hand, are resizing. I’m trying to figure this out now, so maybe I’ll find a solution, but for now I just want you to have as much information as possible.

    #44913

    Tom ( Support)
    Keymaster

    Hi,

    Slide set images will not resize where as an image from a portfolio post is resized automatically so it will fit into the post correctly. If you do want images to open up into lightbox and be the original size, I do recommend using the slide set manager for this.

    You can turn the image resizer off via Appearance > Theme Options > Header > Image resizer. This may help you out but your site may load slower.

    Kind regards,
    Tom

    #44944

    A D Birch
    Participant

    Tom,

    Thanks for writing back. I wish I would edit and delete posts – I have a bad habit of asking questions while I’m learning which leads to questions being sprayed all over a forum. I will attempt to consolidate my thoughts now.

    Going back in last night, I realized that I have two methods of uploading images that are possible, attached media and slide sets. I could do individual portfolio posts, but I have over 500 and I’d probably have to hire someone to help do that. I agree with you, slide sets are the easiest way to do it. However, as far as I can tell, the images in slide sets can’t be ordered by the date they were created. I would like to make a page for ‘latest additions’, where basically I combine all of the various galleries into one, in order by date, but that doesn’t seem possible with slide sets.

    With attached media, everything was working fine, I can combine galleries and sort by date, until I realized that using that method resizes the images down to 800×450 no matter what I do.

    I attempted to turn off the image resizer, but it makes the thumbnails look awful. Thus, I wish I could have the image resizer work for the thumbs, but not the actual images. I don’t suppose there’s one convenient line of code I can comment out to fix everything? Or should I really consider doing the ‘one post per image’ portfolio method? I suppose I could do it that way.

    Thanks for your time and sorry for my dual posts.

    #45015

    Tom ( Support)
    Keymaster

    Hi,

    I will ask Andy about the code side of it but I am unsure whether this will be possible or not.

    Not many people want to mix and match like you are trying to do thats the thing.

    I will get back to you soon.

    Kind regards,
    Tom

    #45111
    Andy
    Andy
    Keymaster

    Hey AD,

    I understand what you mean in the other thread now. I’ll change this for future updates, however you can modify the following file for yourself to get the full version.

    Edit ePix/lib/inc/classes/post-attachments-class.php

    Search for:

    $size="large";

    and change to:

    $size="full";

    I hope that helps?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

© 2019 Acoda