Home Forums ePix Support Google Webmaster: Error: Missing required hCard "author".

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #57339

    Christos Gioris
    Participant

    For example, please check it here:
    https://www.google.com/webmasters/tools/richsnippets?url=http://www.santorini-photographer.com/santorini-honeymoon-photo-session/

    It is a very important ranking factor for google. Please help me solve it. Thank you.

    #57352

    Tom ( Support)
    Keymaster

    Hi Christos,

    This has come up before and the problem arrises when there is a element on the page that is pulling in other posts at the same time as displaying the current one. Google gets confused as to who the author is so doesn’t display anything.

    Please set your reply to private and provide your URL/login details so I can take a further look for you and try to get to the bottom of this.

    Kind regards,
    Tom

    #57388

    Christos Gioris
    Participant
    This reply has been marked as private.
    #57403

    Tom ( Support)
    Keymaster

    Hi Christos,

    Turned out to be something very simple that I forgot about, you didn’t have the author turned on within Appearance > Theme Options > General > Show Author Bio, Posts & Pages.

    It now shows the hcard author.

    Hope this helps.
    Tom

    #57562

    Christos Gioris
    Participant
    #57589

    Christos Gioris
    Participant

    Hi, I have not heard from you for many days. Can you please check it?

    #57599

    Tom ( Support)
    Keymaster

    Hi Christos,

    The hcard author only works on single posts when the Author section is present. When a post is written Google needs to know the author, so it is displayed. A page does not need an author.

    Hope this helps.
    Tom

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

© 2019 Acoda