Home Forums ePix Support Pages | Add Gallery | Data Source:Product Categories NOT working

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #58904

    Alan Fusco
    Participant

    Version 1.3.1

    Pages | Add Gallery | Data Source:Product Categories NOT working

    With Masonry on, they show up on top of each other with the following error: “Warning: Invalid argument supplied for foreach() in …wp-content/themes/ePix/lib/inc/classes/post-categories-class.php on line 433”
    Example: http://imagesbyalanfusco.com/black-and-white/

    With Masonry off, it’s a little better. At least the photos show but it still isn’t correct and the following error message is displayed: “Warning: Invalid argument supplied for foreach() in …wp-content/themes/ePix/lib/inc/classes/post-categories-class.php on line 433”
    Example: http://imagesbyalanfusco.com/architecture/

    Everything was working fine in the previous versions. (You had several that came out relatively quick, I may not have upgraded to those.)

    Alan

    #58929
    Andy
    Andy
    Keymaster

    Hi Alan,

    That’s strange, can you switch through your Data Source and ensure no other sources are selected ie. Portfolio category etc. It appears to be trying to use portfolio category instead of Product. If that doesn’t resolve it, please can you provide your WP login details and I’ll take a look for you. I’m about to board a 12 hour flight, I’ll get to it as soon as I’m back in front of a computer.

    Also, it’s worth replacing ePix/js/jquery.isotope.min.js with the following file, it resolves a loading in issue.

    http://epix.themeva.com/wp-content/themes/ePix/js/jquery.isotope.min.js

    #58946

    Alan Fusco
    Participant

    The file fixed the loading problem but I am still getting the post_categories error even though Product Categories is the source. What is strange is the error is on the Architecture and Black and White page but NOT the Landscape page which is setup the same way. I am adding a private post with login information so you can take a look.

    #58947

    Alan Fusco
    Participant
    This reply has been marked as private.
    #58976
    Andy
    Andy
    Keymaster

    Hi Alan,

    I’ve managed to resolve it. It was the Portfolio Data Source causing the issue. It had selected “No data” but the theme still classed this as an option had been selected. Once I had unchecked the Portfolio category “No data” and saved the page, it worked.

    #59032

    Alan Fusco
    Participant

    Thank you Andy. Everything seems to be working now. I appreciate all of your help.

    #59092
    Andy
    Andy
    Keymaster

    No problem, I’m glad I could help. If you haven’t done so already, please rate the theme here.

    Kind regards,

    Andy

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

© 2018 Acoda